Question

Locked

Help with network drive

By idst.me ·
Hi,
I have an aerolite 10/100Mbps NAS enclosure network harddrive. It is 2TB.
I used to use it wireless but 99% I connect with a USB.
I'm running Windows 7.
Recently my laptop got a virus, so I backed up all my data on the drive. I have reinstalled windows but now when I switch the harddrive on and connect the USB nothing happens - as if it wasn't connected at all.
I hear the windows USB sound whenever I insert/remove the lead to and from my laptop, so at least I know it is registering something going into the USB port, and the red light on the network drive is on. Although the green HDD light doesn't come on now.
I used the drive since the reinstall of my OS, it just seems to have stopped working. I can't hear the disc spinning either. I have tried another USB cable too, thinking the cable may have died on me.
Any sugguestions?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Is there a jack for an external power supply?

by robo_dev In reply to Help with network drive

Sometimes it takes more current to get a drive started than USB can provide.

Sometimes devices come with a USB Y-cable to double the current.

I would try carefully gently shaking the drive in a 'flat spin' in case the bearing is failing.

The next thing to try would be to remove the drive from the enclosure and install it in another enclosure or a PC.

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums