Question

Locked

Hide/Prevent access to drives in my computer fails to block C:

By beng ·
Hi everyone,

Starting to tear my hair out here.

Im trying to reorganise the OUs and Group Policies here and I have set up a new OU and set up a policy and a user all of which is being used by a virtual machine in order to test the policy.

What im trying to get to is that users can access my computer for access to network drives etc but not to c:.

I have set up the prevent access to specified drives from my computer and the hide drives option to be A B C D & E, which works fine for the other drives but no matter what i do i cant hide the c: drive.

I have run rsop.msc to get the list of what has been applied and it seems to have been applied correctly without any errors but stil not doing what it should.

Has anyone come accross this or know away around it? I realise i can lock down the c: drive via NTFS permissions but it would just make more sense if the icon was hidden.

hope that all makes sesne.

Any help would be greatly appreciated.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

yes

by beng In reply to Has the policy had time t ...

Hi there, yes the policy has propogated and the RSOP seems to prove that it has worked.

However some further testing has suggested that something else in the policy is breaking it. i set up a virtual machine of server and client and set up the policy and it worked straight away.

Going to make a copy of the live policy and try and put it onto the virual machine and see how i get on. Im sure its something simple that im missin but just cant spot it.

Collapse -

Fixed

by beng In reply to yes

Fixed it!

It would seem that the policy said it had some "Extra Registry Settings" which from what I have read means that they were set from a computer with a differnt set of .adm (templates) or possibly done from a winxp pc which also causes issues.

Anyway the settings that were applied were the registry keys that control the hiding of drives.

The applied settings were...

Setting State
Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDrives = 27
Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoViewOnDrive = 27

Using the nt drives calculator (which gives you the decimal value to enter to block drives using nodrives key)

http://www.wisdombay.com/hidedrive/index.php

i found that this was only blocking A B D E but not C, so what was happening was that the policy would apply my Hide/prevent settings then further into the policy it then takes the "Extra registry settings" and used that instead as it was applied last.

I didnt spot this in the RSOP console, maybe it didnt show it but of course i was looking for my original policy being applied not the extra registry settings.

Hope this info is of some use to someone, thanks for you help anyway.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums