Question

High Error Output on Trunk Interface - Help Troubleshooting

By matiashuartamendia ·
We have three switches in our company, one of them is the core switch, and the other two is where our client PCs are connected. The switch core also has an ESXi Server connected to it, where all of our services are hosted. Additionally, we have a Cisco ASA Firewall connected to it. In order to monitor our interfaces and other devices/servers, we use Zabbix 4.0.


Everything was working normally, we hired +35 people, and everything is practically the same, however, we are getting alerts on Zabbix about high error rate on output interface Gi 1/0/22, this is one of the trunk ports which is connected to one of our non-core switches where end users are connected to. Sometimes we also receive alerts for interface 1/1/2 which is where our outside interface on the Cisco ASA is connected to, this last one goes away after some minutes, and it only pops-up from time to time.


However, our Gi 1/0/22 alert stays there for over an hour, then it goes away, and re-appears. The cabling of these interfaces was changed two days ago on a schedule where no people was working. The alert still pops up however reducing from an hour to 25-30 minutes. So, that might be an improvement, but I am still concerned about the alert. What other options do we have in order to troubleshoot this issue? Should I post an image of our interface?


I'd be eternally thankful for the help! :)
10 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

response

by abartkiewicz In reply to High Error Output on Trun ...

what type of switches do you have and how many users do you support on each switch?

Collapse -

Catalyst

by matiashuartamendia In reply to response

Catalyst L3 Switches, that's 48 ports per switch, except the core one which has 24, we have 44 users on each switch.

Collapse -

reply

by abartkiewicz In reply to Catalyst

If you do a "show interface gig1/0/22" do you see input or output errors. Any drops? Or do you experience network performance problems?

Collapse -

Catalyst

by matiashuartamendia In reply to reply

There are output drops and errors.

A total of 621664073 output errors.

There are no REAL problems on the infrastructure so far

Collapse -

reply

by abartkiewicz In reply to Catalyst

Okay, that is a lot of errors. Did you check the speed and duplex settings?

Collapse -

reply

by abartkiewicz In reply to Catalyst

Also do the speed and duplex settings look correct? They should be 1000/Full.

Collapse -

Speed

by matiashuartamendia In reply to reply

It says full duplex on the interface which is gigabit ethernet.

It's set to auto negotiate and running at 100mbps

I was told this could be the issue, however, if I set the speed manually I'll lose connection to the main DC and employees wont be able to browse for a while. Any advise on that?

Collapse -

reply

by abartkiewicz In reply to Speed

Okay, I would say that is probably your issue. It needs to match the port speed and duplex on the other side of the connection. Unless the other switch has 100mbps ports they should both be set to 1000/full. I'm guessing that the speed is manually set on one of the sides already. Once you set the duplex and speed I would recommend turning off auto negotiate

Collapse -

Speed

by matiashuartamendia In reply to reply

I'll find out what speed the other port of the switch is set to, and if it is manual or auto. What I can guarantee per show interface command on the core one, the one Im having the issue with, is that's set to Auto, and per consequence 100Mb's. The huge amount of errors is because this issue has been around us for more that 3 months haha.

The cabling was changed, and that improved the situation but it did not terminate it

Collapse -

Speed

by matiashuartamendia In reply to reply

So all of the ports on the non-core switch are 100Mbps except the SFP Modules, and this interface is connected to port 48 which is a trunk...What would be the advise on this scenario?

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums