Question

Locked

Honeypots

By akabee ·
Does anyone know how I can install Netkit on Vmware fedora image in order to create honeypots . I have tried installing netkit on linux but it says the kernel is too old. I need help please.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well it would help if you told us

by OH Smeg In reply to Honeypots

Which version of Fedora you tried this on. But because of the error message that you listed I'm assuming that it was an earlier version of Fedora so have you considered downloading the newest version from here?

http://fedoraproject.org/en/get-fedora

You could grab the Upgrade Version .

Col

Collapse -

I used Fedora 11

by akabee In reply to Well it would help if you ...

I initially used linux redhat 9 and was able to install netkit 2.6 on it but when I tried to create honeypot hosts with it there was an error saying "kernel too old". I discovered that the linux version had kernel 2.4 on it, so I went for fedora as it is a newer version. I was able to save the netkit-2.6.tar.bz2 file, the netkit-filesystem-i386-F5.0.tar.bz2, and the netkit-kernel-i386-K2.7 tar.bz2 files to disk. I was able to unpack the netkit-2.6.tar.bz2 to the home folder but when I tried unpacking the netkit-kernel-i386-K2.7.tar.bz2 tarball it kept freezing at some early stage during the download displaying a dialog message saying "an error has occured in the script". The same thing happened when I tried unpacking the netkit-filesystem-i386-F5.0.tar.bz2 tarball.

Collapse -

I think that you'll find here

by OH Smeg In reply to I used Fedora 11

That the netkit-filesystem-i386-F5.0.tar.bz2

Ids a 32 Bit version of this app for a 32 Bit OS and if you are attempting to install onto Fedora 11 ^$ Bit it will not work. Mainly because Linux doesn't offer cross support for the 32 & 64 Bit Operating systems. If you have the 64 Bit version of Fedora 11 you'll need the 64 Bit version of Netkit and if you have the 32 Bit Version of Fedora you'll need the 32 Bit Version.

With the error message you have given it sounds as if you are attempting to install a 32 Bit Version onto a 64 Bit Operating System.

Also according to the Documentation that comes with the i386 it was designed for a Debian Type Linux which the modern Red Hat/Fedora isn't. That could just as easily be the problem here to.

http://www.netkit.org/download/netkit-filesystem/README

Col

Back to Software Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums