how do i change hard drive settings?

By mckevitt ·
I have read that to downgrade from win7 to XP i need to change the hard disk settings from SATA to IDE?

How do i do this?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Just to clarify this

by robo_dev In reply to how do i change hard driv ...

First of all, SATA and IDE are two different type of drive interfaces, so you cannot change one to the other without buying a new hard drive and/or PC.

But, you really don't need to do that. XP runs fine on either one. It's a bit trickier to install on SATA drives, but it can be done.

In some cases, on some computers, in order for the XP install to work properly, you need to do two things:

1) go into BIOS setup and change the SATA hard drive configuration from RAID to IDE mode. This is sometimes needed so the XP install will not bork. That being said, I have three PCs at the moment running SATA Raid on Windows XP, so I guess I am lucky. In my case I run RAID level-1 which mirrors one SATA hard drive to a second drive, and if one drive dies, you can power down, plug in a new drive and it recovers automagically...but I digress.

2) The other tricky thing is that the first version of Windows XP has no disk driver files for SATA devices (since SATA had just been invented when XP was released). Thus there's an option during XP install that says 'press F6 to install a third-party driver', and you need to have the driver for your SATA hardware on a CD or floppy drive at that point.

Also, the later version of XP (XP SP3) has SOME SATA drivers baked in, but not all.

Collapse -

r you sure?

by markp24 In reply to how do i change hard driv ...

You need to replace the disk to make it a true ide drive. but im a wondering if they really meant change the setting in you bious, for SATA- native/compatible. Try looking in your bios and change the setting to compaitble (or equivilent)

Collapse -

Reponse To Answer

by mckevitt In reply to r you sure?

thanks for your help. It turned out i just had to change the hard drive settings in the bios. I miss read what i was reading, when you read 1000 forums looking for an answer your head tends to become pickled. Thanks

Related Discussions

Related Forums