how do I get dual channel configured on GA-P67A-UD4-B3

By BizIntelligence ·
Hi There,

I recently built a system with following main components:

> Gigabyte GA-P67A-UD4-B3 (rev 1.1) motherboard with BIOS version F3
> 2 X 8GB KIT (Model:F3-10666CL9D-8GBXL and 2X4GB in each kit) = 16GB RAM
> Intel Core i7 2600

I am unable to get dual channel enabled with 4 X 4GB RAM. I ran CPUZ too see if memory is running in dual channel mode and there was nothing in Channel # section. So I tried only one kit which is 2 X 4GB RAM i.e. 8GB from same kit on following slots as per the motherboard manual:

Frist Attempt: DDR3_1 and DDR3_3
Second Attempt: DDR3_2 and DDR2_4

I still didnt get dual channel.

I took RAM modules to vendor (MSY in Altona, VIC) and test them on their system. Their system detected the dual channel. Later that day, when I tested it on my pc again with same combination it didnt detect any dual channel configuration.

I ran both CPUz and EasyTune6 (from gigabyte). I found ET6 was detecting one RAM module on DDR3_1 as PC3-9800G and others as PC3-10700. On the other hand, CPUz detected all of the RAM mondules as PC3-1077. Strange !

So I shuffled the RAM modules (in accordance to combination) and ran both apps again. This time both apps detected all of the modules as PC3-10700. Each RAM module is showing same frequency and other attributes. There must be something wrong either with software or board.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

I would opt for a Software issue here

by OH Smeg Moderator In reply to how do I get dual channel ...

All you need do is fit Identical RAM in the Color Coded RAM Sockets to get the Board running in Dual Chanel Mode.

If you read the Gigabyte Manual it clearly tells you how to fit RAM to the M'Board. As for Compatible RAM you can check the list here


Unfortunately the World Site is down at the moment so I can only send you the AU Site for Gigabyte and this M'Board.


Also look in the BIOS Section of the User Manual and make sure that you have not disabled the Dual Chanel RAM Option if that is even an option for this M'Board.

You can download the user manual from here if you no longer have the one that came with the M'Board.



Related Discussions

Related Forums