Question

Locked

How do I get Exchange 2003 and 2010 to talk to each other?

By FCometa ·
Hi. I recently installed an Exchange 2010 server in my Exchange 2003 organization. I only have those two servers. I moved some of the mailboxes on the legacy server to the new one. The thing is I can only send e-mail to external recipients: I can't send mail from a user on one server to the other. I have checked the integrated authentication checkbox (and all others for that matter), which seems to be the case most of the time. The two servers communicate by means of a VPN between two Cisco ASA appliances. Strangely enough, I can telnet to port 25 and EHLO successfully each server from an Ubuntu laptop, but with a telnet from one server to the other (and even a Windows laptop), a EHLO get an "Unrecognized command" error. I just don't get it. Help, please!!!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Bridgehead ? front end back end?

by CG IT In reply to How do I get Exchange 200 ...

if the Exchange servers are in different locations,how you set it up determines how it operates.

a bridgehead mail server handles mail for the domain. Front end back end is as the term implies, a front end sends and receives and the backend distributes.

how do you have your exchange servers setup to handle mail?

Collapse -

More info

by FCometa In reply to Bridgehead ? front end ba ...

Yes, they are in different locations. The Exchange 2003 is not set up as a front end server (it was the only server we had until now). The Exchange 2010 server has the CAS, Hub Transport, Mailbox and Unified Messaging roles. The installation automatically set up routing group connectores between both servers. Now that we're on the subject, on the Exchange 2003 side you'll see the queue for the routing group connector fill up with messages that will eventually bounce back with an undelivered message. The error is constantly "451 5.7.3 Cannot achieve Exchange Server Authentication". The other server has a "smtprelaytotirg" queue corresponding to the routing group connector that also fills. Continuing on, each server has an external DNS entry pointing to it ('legacy' and 'mail'), so right now each one can send/receive external mail.

Collapse -

relaying is turned off and not allowed by default with SP3 on 2003

by CG IT In reply to More info

and I belive by default with 2010 automatically. could be why your having an authentication problem with the connection.


if your connector fills up, sounds like a mail routing problem. what are the routing groups? are you using the wild card as a route group?

Collapse -

Follow up

by FCometa In reply to How do I get Exchange 200 ...

On the Exchange 2003 server, I granted permission for the Exch2010 server to relay, along with the checkbox that allows all autenticated servers to relay. The routing groups configured are two SMTP connectors, one for each server, with the address * that permit each server to communicate with the outside world, and the two automatic routing group connectors that are created with the installation of 2010.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums