How do I set up Exchange to receive emails once I change the MX records

By mlieberman ·
We just got a static IP and are changing the MX records on our external webhost to point to our internal Exchange server 2003 on SBS 2003 that all emails can be received via exchange as opposed to just internal office emails. I looked around and it just seems like I have to make sure that there are accounts on the exchange server that reflect the domain correct? So an email going to should have an account on the exchange server that is Is that all I have to do, or is there more to it?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: Exchange

by christianshiflet In reply to How do I set up Exchange ...

If Exchange is already functioning internally with working SMTP connectors the main change you would need to make would be to forward the appropriate ports through your router so inbound mail makes it to your server. The ports are typically 25 (SMTP), 110 (POP3), 143 (if you support IMAP), and 143 (for Outlook Web Access).

I hope this helps. If you have already done this and are still not receiving email, let us know. Thanks.

Collapse -

It still doesn't work

by mlieberman In reply to Re: Exchange

I changed over the MX records and I have everything forwarding over, and I know in the very least it reaches our server correctly because any emails don't reach our backup MX record which is my external webhost. I am forwarding the ports correctly. Is there anyway to check? I am using SBS 2003 which I know sometimes has slightly different settings for things. I know I had to change a lot of SMTP connector settings before we got our static IP because verizon didn't allow us to forward through their smart host, and we were on a dynamic IP so a lot of email servers would block us by default, so I don't know if there's any setting I might have changed that might be blcoking something.

Collapse -

Re: Not working

by christianshiflet In reply to It still doesn't work

Well, I assume that you can still send and receive internal messages as well as send email outbound. Is that correct? If so, can you telnet into the server on port 25 from both the LAN and the Internet? Is the server firewall turned off or configured to allow inbound traffic? And lastly, regarding your old dynamic IP, did you happen to setup anything for dynamic DNS with a third party that may be misdirecting your inbound messages such as DynDNS?

Please let me know. If you cannot Telnet into the server from the Internet using both the static IP and the MX record name what message do you get? Thanks.

Collapse -

Answers to your questions

by mlieberman In reply to Re: Not working

I can telnet from both the LAN and the internet. I get

220 (domain omitted) Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Fri, 3 Apr 2009 10:46:42 -0400

IMAP and POP3 are also accessible correctly as I can telnet into them as well.

as the message. I did have a dynamic dns through dyndns, and I think its still set up on our router to update so its still set up. Could that be causing some sort of conflict though? Its only set up as a forwarding service so [whatever] would forward to our internal website so people could log in and download the VPN client, have remote access, be able to view outlook web access etc. Should I disable that? When I did set up the MX records I just had it go directly to our static IP, I didn't use any forwarding via dyndns.

Collapse -

What I would do

by christianshiflet In reply to Answers to your questions

First, I would disable the DynDNS service. With the static IP you don't need it anymore and I suppose it could be causing some issues (but I doubt it). Users can now log in remotely using your static IP. Since you can telnet into your server, the problem is most likely in your SMTP virtual server rejecting outside domains.

Check out to test your SMTP access more thoroughly. Please let me know what the results are. Thanks.

Collapse -

MAIL FROM: does not work

by mlieberman In reply to What I would do

I started running through the tests that you suggested and most work except MAIL FROM: which gives the error

500 5.3.3 Unrecognized command

Also RCPT TO: gives me the error 503 5.5.2 Need Mail From: first

Collapse -

I forgot to mention

by mlieberman In reply to MAIL FROM: does not work

AUTH LOGIN gives me the message

504 5.7.4 Unrecognized authentication type

I'm not sure if I set up AUTH for the SMTP server/connector? I am not sure which I'm even supposed to be really using.

Collapse -

Re: mail from

by christianshiflet In reply to MAIL FROM: does not work

Firstly, with server 2003 I believe ehlo has to be changed to helo. Additionally, the error you are getting seems to happen if you don't have a space between "MAIL FROM:" and the address. Is that a possibility? Please let me know. Thanks.

Collapse -

I checked all of that

by mlieberman In reply to MAIL FROM: does not work

I checked, it is EHLO and I checked every variation of mail from. mail from <email>, mailfrom <email> mail from:<email>, mail from: <email>.

Collapse -


by christianshiflet In reply to MAIL FROM: does not work

Try, instead of AUTH LOGIN, AUTH NTLM LOGIN. Let me know the results. Thanks.

Related Discussions

Related Forums