Question

Locked

how do I upgrade Cisco IOS on a switch that is not on a network yet?

By JPru22 ·
I have a couple of 3750 switches that I need to upgrade before I put them on the network. How can I do this with TFTP instead of xmodem because I keep getting an I/O error when trying to use xmodem. The one thing I tried is connecting my PC via Ethernet to my switch, I used IP address 10.10.10.3 on my PC NIC and then used 10.10.10.1 for my VLAN1 on the switch. I could ping the switch form the PC, but I could not ping the PC from the switch. I even tried using 10.10.10.3 as my default gateway on the switch and that did not help either. Can anyone help me out on this or let me know of an easier way that I can upgrade these switches.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Subnet masks match?

by robo_dev In reply to how do I upgrade Cisco IO ...

can you telnet to the switch?

Does the PC have a personal firewall or have Windows firewall enabled?

Collapse -

to answer your question

by JPru22 In reply to how do I upgrade Cisco IO ...

Thank you for the response robo_dev....yes the masks are matching 255.255.255.0, basically I have a console set up to help me configure the switch from my PC at my desk, then I connected an Ethernet cable between the switch port f1/0/1 and my laptop. no other connections to/from the switch. Also no FW enabled on the laptop.

Collapse -

Interface shut down?

by robo_dev In reply to how do I upgrade Cisco IO ...

http://forums.techarena.in/networking-security/1129920.htm

from the above forum:

"You might have a problem with your default gateway command - the 'default gateway' command only sets the DGW for the console. It's the 'ip route' command that determines routes for the interfaces.

If you can ping the router, the 'ip route' is correct. If you can't telnet, you need to fix your 'default gateway'."

Collapse -

more info

by JPru22 In reply to how do I upgrade Cisco IO ...

I thought that same thing, I ended up trying a lot of things, such as deleting the DG and trying to add a route, but the route never took, how do you add a route from a switch that has a direct connection to a PC with nothing in between. I kept getting an error, but sadly did not jot it down. Either way I am in a huge hurry to get this done and so I ended up grabbing a spare IP address and port and giving the switch a basic config just so I could tftp from my PC. Nearly complete with this now, but I do thank you so much for your time in trying to help me get this resolved. I really thought there was an easy way to do this, for instance I remember setting up an ASA not that long ago and had to configure it before it was on the network, i was not familiar with the CLI on an ASA so all I did was give it a management IP and then set up my laptop NIC on the same network range and then just connected an Ethernet cable in between so that i could access the device via ASDM. I do not remember putting any special routes or anything. Oh well, that's networking. Again, i appreciate your time and swift response.

Collapse -

Network troubleshooting from a switch

by nwallette In reply to how do I upgrade Cisco IO ...

This is prone to all sorts of confusion. There are a couple reasons why this could be.

First, a pretend network. Say you had two VLANS, 1 and 2, and they were assigned 10.0.1.1 and 10.0.2.1 on each, respectively, and ports 1 and 2 were assigned to VLANS 1 & 2 respectively.

The first problem is, if (for e.g.) port 1 is in access mode but there's no physical link (or it's admin shutdown), VLAN1 will not be "up" either. There *HAS* to be at least one port in that VLAN up before the VLAN itself will be up. (The switch will still forward packets over a trunk interface within VLAN1, but the management IP will not be accessible.)

So, Rule 1: Make sure you do at least this:
interface vlan1
ip address 10.0.1.1 255.255.255.0
no shutdown
interface fastethernet 0/1
switchport mode access
switchport access vlan 1
no shutdown
!

Next, if you tried to ping 10.0.1.3 from the switch, it may not work. Why? Because the switch may "source" the ping from the wrong place. Try this:

ping ip 10.0.1.3 source 10.0.1.1

This will ensure it comes from the VLAN1 management IP. You don't need any routing for this because it's in the same subnet. You only need routing enabled and a default gateway if you're going to jump subnets at some point in that packet's life.

If your switch has routing enabled, you might do well to use something like "ip default-network 10.0.1.0" to define your "main" or management subnet, but there are subtleties to that command which I haven't bothered to learn about. I'm trying to avoid Cisco in favor of stuff like Juniper these days.

If you want to telnet or SSH to the switch, you'll need to define these in the vty config:

username admin privilege 15 secret MyPassword
line vty 0 15
transport input telnet ssh
login default local
!

Once you're in the exec shell (either by telnet/ssh or serial console) you can try copying the config file to test your setup:

copy run tftp
[Follow prompts]

If that works, you can move on to copying the firmware image.

If all this fails, you may have more luck at the ROMmon.

Hope this helps some.

Collapse -

rocket science

by CG IT In reply to how do I upgrade Cisco IO ...
Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums