How to bridge local network to Internet on Cisco 851w

By LisaNels ·
After working on this router for about a week now, I've got everything working on it (I think) with the exception of the link between the internal network, and the Internet.
I'm very new to This type of device, and have used the CLI and also Cisco's CPP. So I thought I'd work on it until it drove me crazy... thus my post!

Setup: House network on using both wired and wireless clients. PPPoE connection to

The DHCP I have running seems to work, but I do not get any info that comes from the connection to Qwest. (Nameservers) Only what I put in the DHCP setup. I also do not know how to check the DSL connection other than seeing a valid IP address for the Dialer interface.

I can ping between the wired and wireless devices on the internal network. I'm pasting my whole config with the passwords changed for security.

Any help would be greatly appreciated. I've learned a lot in the last week, but this part has got me stumped.


Using 2952 out of 131072 bytes
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Cisco851w
logging buffered 51200
no aaa new-model
crypto pki trustpoint TP-self-signed-224790426
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-224790426
revocation-check none
rsakeypair TP-self-signed-224720426
crypto pki certificate chain TP-self-signed-22470426
certificate self-signed 01 nvram:IOS-Self-Sig#A.cer
dot11 syslog
dot11 ssid Lisa
vlan 1
authentication open
no ip dhcp use vrf connected
ip dhcp excluded-address
ip dhcp pool sdm-pool
import all
lease 0 0 10
ip cef
no ip domain lookup
ip domain name .local
username lisa privilege 15 secret 5 $1$Zt/y19UTIM1
log config
bridge irb
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface FastEthernet4
description $ETH-WAN$
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
interface Dot11Radio0
no ip address
ssid Lisa
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
interface Vlan1
no ip address
ip tcp adjust-mss 1452
bridge-group 1
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname
ppp chap password 0 baPjB74Bgw
interface BVI1
ip address
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
access-list 1 remark INSIDE_IF=BVI1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit
access-list 23 permit
access-list 23 permit any
dialer-list 1 protocol ip permit
no cdp run
bridge 1 protocol ieee
bridge 1 route ip
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
scheduler max-task-time 5000


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

I think I see the problem

by NetMan1958 In reply to How to bridge local netwo ...

After looking over your config a second time, I see 2 things.
(1) I don't see a default route. Try adding the following:
ip route dialer0

(2) Under your dhcp pool you have "import all" which should import the DNS servers handed out by your ISP. However you have also "hard-coded" a DNS server with:
Try removing that and then see if your dhcp clients(the computers on your network) get dns servers from your router. You also try running "sh ip dhcp import" on your router.

Related Discussions

Related Forums