Question

  • Creator
    Topic
  • #2146390

    How to configure configure static nat with secondary IP?

    Locked

    by petersan.jeanpierre ·

    I am deploying a cisco 2621 as perimeter router. I would like to configure fast ether 0/0 with ip 66.236.40.121 as primary and 66.236.40.122 as secondary ip. In addition, I want to use Dynamic nat on 121 for my 192.168.1.0 network (fast ether 0/1) and allow only inbound traffic over port 443, 4621 going to server 192.168.1.157.

    is it possible to accomplish if so can someone give me an example?

All Answers

  • Author
    Replies
    • #2461369

      Clarifications

      by petersan.jeanpierre ·

      In reply to How to configure configure static nat with secondary IP?

      Clarifications

    • #2461338

      Read more here..

      by Anonymous ·

      In reply to How to configure configure static nat with secondary IP?

      http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

      Please post back if you have any more problems or questions.

      • #2462895

        How to configure configure static nat with secondary IP?

        by petersan.jeanpierre ·

        In reply to Read more here..

        The reply is very helpfull and I wish I had that a few days ago. What I am realy trying to achieve is this.

        interface FastEthernet0/0
        ip address 66.236.40.131 255.255.255.224
        ip address 66.236.40.132 255.255.255.224 secondary
        ip nat outside
        ip access-group Filter_WAN_In in

        interface FastEthernet 0/1
        ip address 192.168.1.1 255.255.255.0
        ip nat inside
        ip access-group Filter_LAN_In in
        ip access-group Filter_LAN_Out out

        ip nat inside source list 1 interface FastEthernet0/0 overload
        ip nat inside static tcp 191.168.1.113 25 interface FastEthernet0/1 25

        etc.

        access-list 1 permit any

        ip access-list extended Filter_WAN_In
        permit ip any any
        deny ip any any
        ip access-list extended Filter_LAN_In
        permit tcp any host 192.168.1.113 25 any 25
        permit ip any host
        ip access-list extended Filter_LAN_Out
        permit ip any any

        With the above configuration, as you can see I am trying to use two ip addresses on the same interface FastEther0/0

        What I would like to do is allow the inside network to use the first ip for nat translation dynamic translation and use the second ip address for specific static connection with internal servers like a mail server etc.

        before I configure nat on outside interface, I am able to ping both IP’s. Once nat is configured, I can only ping the primary ip not the secondary.

        my question is can I physically configured the router to make use of the above implimentation? Since I am new to CISCO, I don’t a whole lot about router configuration to determine if what I am trying to do is even possible.

        If what I am trying to accomplish is not possible can I get an alternate solution?

        • #2462884

          I can see the figures but i need to know what in terms of use..

          by Anonymous ·

          In reply to How to configure configure static nat with secondary IP?

          You are trying to implement, IE. server to workstations. Sorry but i need the “machine 1 to connect to machine 2. You can set the router(s) for “Auto” in the router settings. If you have two routers and you need to have one “inhouse” then you can set one to “adhoc”.
          Just need more hardware info.

          Please post back if you have any more problems or questions.

Viewing 1 reply thread