Question

Locked

How to configure QOS for cisco router?

By johnpeeris ·
Dear all,
I want the QOS configuration on cisco
router.If anybody knows about the configuration
pls give the details.

With Regards,
John peeris.P

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

QoS

by Jellimonsta In reply to How to configure QOS for ...

What QoS level do you want to configure? What devices is the QoS for? Do you want QoS across the LAN, or WAN? What kind of WAN circuit do you have?

If you have Cisco IP phones and Cisco switches you can configure auto qos on the switch to trust dscp markings from the phones.
Otherwise, the following link may help.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.2_44_se/configuration/guide/swqos.html

Regards.

Collapse -

Thank you for your response

by johnpeeris In reply to QoS

Dear Jellimonsta,
Am pleasure to see your reply.I want to configure QOS for voice in the router.Awaiting for your reply.

With Regards,
John Peeris.P

Collapse -

QoS on the router

by Jellimonsta In reply to Thank you for your respon ...

For Cisco VoIP, your best bet would be to create a class map to define and use policy maps to mark the traffic and prioritize.

Please note however, that if you are using a broadband connection to the Internet, that your QoS policy will be pretty much moot. Your QoS policy will only affect the traffic in how it is queued and marked. But delivery of the voice packets over the Internet are still best effort.

If you have a dedicated (leased) line, or MPLS VPN, it will prioritize the traffic at the edge and forward voice packets first (minimizing impact of delay and jitter).

I would recommend a separate VLAN and subnet for your voice class traffic (below example uses VLAN 2 with supposed IP 192.168.2.0/24), and defining a class map and policy map as below.

ip access-list extended VOICE-SIGNALING
permit tcp 192.168.2.0 0.0.0.255 any eq 1720
permit tcp 192.168.2.0 0.0.0.255 any range 11000 11999
permit udp 192.168.2.0 0.0.0.255 any range 2427 2428
permit tcp 192.168.2.0 0.0.0.255 any range 2000 2002

ip access-list extended VOICE
permit udp 192.168.2.0 0.0.0.255 any range 4000 32767

class-map match-all VOICE-SIGNALING
match access-group name VOICE-SIGNALING
class-map match-all VOICE
match access-group name VOICE

policy-map EDGE-QOS
class VOICE
set ip dscp ef
priority percent 35
class VOICE-SIGNALING
set ip dscp af21
bandwidth percent 10
class class-default
set ip dscp default
bandwidth percent 30

interface x (where x is your outside interface)
service-policy output EDGE-QOS


This does not mean that default traffic cannot take the bandwidth allocated to voice, so do not fear you are cutting down on bandwidth for data class traffic, it just defines it cannot take the whole link during congestion (which is the purpose for QoS).
Regards.

Collapse -

Reponse To Answer

by qosnewcomer In reply to QoS

Dear Jellimonsta,

I saw your answer and I would like to ask you for an example about how to deploy QoS for voice in the router, currently I have the following escenario:

It is intented to use a link to the internet, this will be connected to fa0/0 on a cisco 2801 router, an a fortinet firewall will be connected to fa0/1, bellow it will be an asterisk pbx.

Please could you show an example about how to deploy QoS for this escenario?

Thank you very much for your help.

Collapse -

QOS configuration

by johnpeeris In reply to How to configure QOS for ...

Dear Jellimonsta,
Very Pleasure to see your reply.I got a idea with your reply,i will implement this in my network and get back to you.

Regards,
John Peeris

Collapse -

QoS configuration

by brammeke0207 In reply to How to configure QOS for ...

Hello,

I've implemented you're configuration but it seems that i don't get any marked packets, it all goes to class class-default. Can you help me with it?

brammeke0207

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums