Question

Locked

How to find a missing Hard Drive?

By jp81 ·
I can't pinpoint when it happened, but my HP Pavillion desktop has lost a previously working SATA drive. It was a Maxtor secondary storage drive. The system drive is a Samsung SATA and it is working fine. I am running Windows XP media center edition SP2.

The Maxtor shows up in the BIOS and passes all SMART tests, but when Windows XP loads the drive is no where to be found. It is not listed in Disk Manager or Device Manager at all. I installed a new Western Digital 500GB SATA and got the same results. Put the Maxtor in a USB2 enclosure and there is was working fine with all the data. Ran an error check, defragged and it has been working fine as a USB external. The only clues I have as to why it didn't work internally are some error messeges in the system logs during start up.

I find some error messages in the system logs after booting referencing source: atapi and event: 9 and 11. The following lines are copied from the event properies of these errors.
The device, \Device\Ide\IdePort3, did not respond within the timeout period.

The driver detected a controller error on \Device\Ide\IdePort3.

I have updated the BIOS, swapped out SATA cables, ports and power connectors from the system drive with no change. I believe all the drives are SATA II/300 but something has to be different about them. I am suspecting a wierd virus, a registry issue or something in windows XP that is not recognizing the second SATA device. This one is very puzzling and has stumped anyone I have asked about it.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

chkdisk

by mikedawgy In reply to How to find a missing Har ...

have you ran a chkdisk on your system? You can also boot into safemode hit run and type in regedit. You can go through and delete all the files of programs that you've downloaded that you don't use anymore. However deleting from regedit it is very unforgiving. Also if you have installed other operating systems such as Linux or OpenSolaris and you have restored your system, those files are still on your disk. I would invest into getting drive scrubber and wipe the hard drive. I would set it up to wipe about seven times, which would take at least three days. The if you just reformat your disk it does not get rid of the old files it just covers them up, it is best to wipe the hard disk and then reinstall your os

Collapse -

Try disconnecting

by Jacky Howe In reply to How to find a missing Har ...

your CD/DVD optical drives and see if you still have a problem.

Update your Chipset drivers.

let us know how you get on.

Edit: to add

It maybe a faulty cable or a failing CD/DVD drive.

Collapse -

Also as this is a SATA Drive

by OH Smeg In reply to How to find a missing Har ...

Try disconnecting it and reconnecting at the M'Board to a Higher SATA Drive Number than the Boot Drive.

Many M'Boards prefer to have the Boot Drive as the Primary SATA Connector 0 and the Slave Drives connected higher up the Drive Chain. I have seen cases where it is impossible to install the OS onto a HDD not on the primary SATA Controller.

Col

Collapse -

Have tried most of these already

by jp81 In reply to Also as this is a SATA Dr ...

Thanks to all for the suggestions. I will consolidate one reply to all three previous replies.

I have run dskcheck on the system drive, but couldn't get to the secondary drive until it was connected via USB. I have a project I must complete over the next couple of days so I am not comfortable trying anything to drastic such at registry edits.

I have tried other SATA ports, swapping SATA Cables and moving the system drive to the other ports (without the secondary drive connected.) System drive always works under any config, but not the secondary drive.

I will look for updated chipset drivers and try disconnecting the DVD drive (it is PATA.) The DVD does appear to be working fine as far as I can tell.

I will post again when I can try some of these.

Collapse -

Registry

by mikedawgy In reply to How to find a missing Har ...

I had recently deleted windows 7 rc and reformatted my hard drive and put wxp back on. My computer had ran fine untill then. Even though I had reformatted my hard drive, bits and pieces of the windows 7 rc was hidden in the registry. My computer was saying that I had a corrupt hard disk and was facing failure. I booted up into safe mode and thoroughly went through my registry and that's when I found the windows 7 rc files. After I deleted the files I ran a wipe on the free space using ace utilities, you wouldn't believe the stuff that the wipe was cleaning out. Since then it has been as if I had a new computer. you can find ace utilities at www.downloads.com.

It's worth a shot.

Collapse -

The reason for this is because

by OH Smeg In reply to Registry

The Format Option Under Windows only looks at every third Sector of the HDD leaving 2/3 of the HDD untouched.

If you used the Fast Format Option it only altered the Partition Tables and rewrote them so the contents of the HDD remained untouched.

Ideally to prevent this happening you need to run a Wiping Utility like Kill Disc and you would have saved yourself the trouble of needing to mess around.

Col

Back to Malware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums