Question

Locked

How to Fix Network Corruption

By RonNewYork ·
I have an XP Media Center desktop, LinkSys WRT310N V2 router, and a Notebook (Win7). Both the XP and W7 are wired into the router. My Droid phone connects via the router's wireless.

Today, on the XP computer when I tried to go to some web sites, there was an automatic attempt to log into MySpace (which is on the web sites; ScienceBlogs and ZDNet). Logins failed. Then, I went to a blog and most of the blog entries had "Invalid URL" instead of the actual link. The W7 laptop had no problem; the Droid (2.2), connecting via the wireless, had same problem. A few days ago, I couldn't reach nytimes.com, and only nytimes.com. Rebooting solves the problem. I tried "resetting' the tcpip stack via netsh int ip reset resetlog.txt, but that doesn't help. This problem has been happening with various manifestations for a while. I changed routers, also. All my anti-virus software says nothing is wrong. Again, rebooting solves the problem.

Update: Rebooting sort of helps but does not solve. Just now (about 1/2 hour after I rebooted), I tried to go to another web site and got a 404. When I tried this on my Win7 machine, no problem. Note: I can ping the unreachable site, but cannot get it via http.

Update 2: And with no further rebooting, the previously unreachable via http web site is now reachable.

I can't figure out why the Droid's wireless connection was similarly corrupted, perhaps by the XP. It's all very confusing to me.

Any help is appreciated.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

probably the SAPS software running "on the mumbo"

by CG IT In reply to How to Fix Network Corrup ...

reboot fixes it.

Collapse -

Have no idea what you mean

by RonNewYork In reply to probably the SAPS softwar ...

On the mumbo? And what SAPS software? Also, rebooting sometimes fixes it for a while, but this time, not.

Collapse -

sonar accoustic processing software ie SAPS

by CG IT In reply to Have no idea what you mea ...

SAPS software "runs on the mumbo" when what it hears isn't in the database. It does a close match to what is in the database thus labels what it hears inaccurately.

Rebooting removes the unknown until it hears it again.

What does this have to do with your problem? Not a damn thing.

but then your in IT, so what's going on with your handheld device should be pretty easy to troubleshoot using fundamental principles of networking.

you said this? " I tried "resetting' the tcpip stack via netsh int ip reset resetlog.txt, but that doesn't help"

which indicates you have more than a rudamentary understanding of networking so, using fundamentals, you ought to be able to track down what's causing your handheld, not to get to the internet pretty handily.

the problem is getting to the internet. because the handheld's networking is based upon wireless technology, what's the first place one should look if getting to the Internet is the problem?

Collapse -

Networking is not my area

by RonNewYork In reply to sonar accoustic processin ...

I just read things on the net and tried them out, in desperation. The main problem is the XP computer, which has to be rebooted at least once a day due to some thing wrong with TCP-IP (I assume). When the computer screws up, I can ping any web site, but I cannot retrieve files via HTTP. And, my network mappings are gone as well.

The XP computer is hard wired into the router. This is my second router in an attempt to fix the problem. The Win7 laptop, which is also wired into the router never has a problem. Today was the first time I noticed that simultaneous with the beginning of the problem on the XP computer, the cell phone also had problems with the same sites, in the same way.

This has been going on for months.

I've posted msgs on many forums and absolutely no one has had the slightest idea, or at least has never told me.

AND as of recently, it is much worse. Random sites now come back as URL Not Found.

I found that by unplugging/replugging the router, the connect is OK. But, this is my second router and if it is the router or the connection of the computer to the router, how do I diagnose it?

Collapse -

Well, for starters

by robo_dev In reply to Networking is not my area

when it's failing:

Can you ping the IP address of the router?

Can you connect to the setup web page of the router?

Can you surf reliably by IP address? E.G. type 170.149.173.130 into your web browser for the NY Times.

if you goto a command prompt and do a NSlookup (e.g. Nslookup www.nytimes.com), it should give a valid response.

nslookup www.nytimes.com
Server: router.my.domain.com
Address: 192.168.0.1

Non-authoritative answer:
Name: www.nytimes.com
Address: 170.149.173.130

One of the most common symptoms of Virus or malware infection is if DNS stops working, as many viruses hijack DNS for their own purposes.

So is your Anti-virus software up-to-date and are there any other signs of virus or spyware infection?

Collapse -

Thanks. I will try this when it happens again

by RonNYC In reply to Well, for starters

My antivirus softeware is AVG and it is up to date.

RON

Collapse -

one of the things about Win7 is that it supports IPv6

by CG IT In reply to Thanks. I will try this w ...

natively. XP typically doesn't support it natively. So if there is a problem with your IPv4 router, IPv6 will work hands down every time, because its bypassing your IPv4 router's firewall and other routing functions. It's as if it's directly connected to the Internet. One of the reasons for sparse adoption of IPv6 by business. Majority of router firewalls and IPS systems didn't filter or inspect IPv6 traffic.

Some URLs don't work because of certificate errors though the browser should warn you of the error. This is specially true on phones. Wireless isn't 100% connectivity like wired. There are many factors effecting wireless connectivity that can temporarily block connections to a access point.

404s in a web brower most typically indicate a DNS problem in that ISP DNS servers are unavailable. if your getting addressing and DNS from the router DHCP, try static addressing.

While TCP/IP stack corruption was prevelent in W9X and IE6, not so much in XP and greater with IE7 and greater. Don't think the problem is continual TCP/IP stack corruption unless your heavily infected with malware.

Run malwarebytes and see what that turns up.

Collapse -

Results when it failed

by RonNYC In reply to Well, for starters

NSLOOKUP failed with a time out
I cannot surf via ip address
I cannot ping or surf to the router's address.
Recycling the router didn't solve the problem at all. I had to restart the computer.

RON

Collapse -

if you can not ping, you don't have connectivity

by CG IT In reply to Results when it failed

If your rebooting the PC and that solves the problem, what's happening is the computer is contacting DHCP to get an address. If it works for a while, then stops working, sounds like malware/virus. Run malwarebytes.

if that doesn't fix the problem, while the PC can not ping the router, run ipconfig/all at the command prompt to determine your addressing, default gateway and DNS servers.

Compare to your local network settings. If their different, run malwarebytes, if their not different, run malwarebytes.

If the problem persists after running malwarebytes and antivirus software, save what you want to save, then reload the operating system.

If you don't want to reload the operating system, try installing a new network card. If that doesn't fix the problem, reload the operating system.

If you still don't want to reload the operating system, then good luck.

Collapse -

For a test, temporarily bypass the router

by dave In reply to How to Fix Network Corrup ...

Connect directly to the internet provider modem with the XP machine and see if that works. At least you will eliminate the modem as the cause.

Back to Social Networking Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums