General discussion

Locked

how to make suse 9 allow win xp to print

By roydv1 ·
we have recently loaded suse 9 (linux) on a pc and want to use it to store data and to use it as a printing station for windows xp machines how would we have to configure it so that we have access to save files in folders on it and to allow us to print. at tne moment we can see the linux pc on our network and we can get in to the pc,and see the folders and printer but we cant open the folders and we cant print to it,it says we do not have access. but we created users for all the people that work here (on the linux Pc ) Please help!!!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by bmedlock In reply to how to make suse 9 allow ...

Are you using Samba?
If you are can I see your smb.conf file?
If you aren't you need to. Check out http://www.samba.org.
Samba is THE program that allows you to network Windows PC's to Linux.

Collapse -

by bmedlock In reply to

OK, I just reread your post, I must have skimmed earlier, you must have samba configured by what you're experiencing. Check your permissions. Linux permissions are VERY different form Windows ACL's. If you have a folder you want all users to access make sure all users are in the "users" group, then "chgrp users \etc\foo -R" assuming the folder is "\etc\foo" Also make sure the group was rwx permissions. If you want everyone to have full access "ls -l" should return "drwxrwxrws 1 root users" or something similar. If there's still trouble, can I see your smb.conf?

Collapse -

by jmgarvin In reply to how to make suse 9 allow ...

Make sure your permissions are correct. That means you need to make sure that the users have at least Read and eXecute permissions.

Also, make sure you smb.conf is properly setup for that specific printer.

Collapse -

by Styopa In reply to how to make suse 9 allow ...

It sounds as though you need to change the access controls in /etc/samba/smb.conf. The easiest way to edit this is in your web browser using SWAT (but if you have a nicely-commented smb.conf make a copy first, or you will lose all your comments). Setting "guest ok = yes" in the [printers] section may solve your printing problem. You could do the same for your file shares, but if you are trying to give each user exclusive write access to his/her home folder, you need to set up a Windows password database on the Samba server using smbpasswd (because the XP machines will only send encrypted passwords which can't be verified against the Linux password file). Once you've got that working you can look at more ambitious concepts such as domain security and synchronising Linux and Windows passwords...

Back to Linux Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums