General discussion

Locked

How to prevent Remote Desktop Timeout?

By EdNetman ·
I have a bit of a problem. We have a server with a few security applications running on them. We connect to the server using Remote Desktop When we connect to the server and initiate the program, sometimes we are timed out before it finishes. There is a GPO that limits connects to 30 minutes when idle. Some of the scans we do take a few hours, so we will minimize the connection while we do other work. This is usually when the timeout occurs. But the software is running, so I don?t understand why it thinks that the connection is idle! I have tried running and old school style mouse trembler from within the session, and it doesn?t seem to help.

Is there any way to force the connection to stay active? Does anyone know of a program or script that will make the remote desktop connection think it is being actively used even when minimized?

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
Thread display: Collapse - | Expand +

All Comments

Collapse -

2 possible solutions

by jim.azar In reply to How to prevent Remote Des ...

Is the Remote Desktop Session being terminated? Or, can you log back in and your session is still alive?

If the RD session is terminating, you can find the session timeout settings in the terminal services configuration, under the administrators menu on the server.

If your session is just becomming disconnected, then it may be that the screen saver is the problem. To solve this problem, just log into the server using Remote Desktop, and then right click on the background of the desktop, select properties, the uncheck the box that requires password on resume.

I hope this helps,
Jim Azar
http://www.rhinoback.com

Collapse -

Another solution

by dasilvakev In reply to 2 possible solutions

You have a GPO that pushes out these settings so why not change that, or create another GPO for the admins and set the timeout value higher?

Collapse -

TR to the (reference) rescue

by Geekenstein In reply to 2 possible solutions

A gold star to Jim Azar and TR. This is another example of useful, easily found information.

Collapse -

pure gold

by solarwes In reply to 2 possible solutions

old post, but still very helpful. i didn't even realize the screensaver was turning on; i thought it was just timing out.

thank you.

Collapse -

Thanks!

by rastr In reply to 2 possible solutions

It was the screen saver- thanks much!

Collapse -

Increase time out

by aks_mcsd In reply to How to prevent Remote Des ...

Open control Panel -> Administrative tool->
Setting-> Terminal Services Configuration->
Connection->RDP-tcp->Session->
Idle Session Limit ->30Minutes

Collapse -

Registry Setting?

by dave.rowe In reply to Increase time out

Is there a registry setting to accomplish this? We have a large number of servers experiencing the same thing and we'd like to change it programatically. Thanks!

Collapse -

VB script that will do it

by JasonEU In reply to How to prevent Remote Des ...

paste this in a notepad, name it something.


Do While True ' keep on getting on
Set objIE = CreateObject("InternetExplorer.Application") ' create an internet explorer instance
Wscript.Sleep 1000 ' wait a bit
objIE.Quit ' kill internet explorer instance
Wscript.Sleep 60000 ' wait a bit
Loop ' do it again!

Collapse -

Look! A VIRUS

by hawngeoff In reply to VB script that will do it

Read the code! That is a virus. Don't do it!

Collapse -

Not a virus

by JoelV In reply to Look! A VIRUS
Back to IT Employment Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums