Question

Locked

How to rectify messed up Share permissions?

By Shorsh ·
Dear all, I tried to set up user permissions to share a partition with my main user account (administrative rights, use only for system operations) and with a limited account (primarily use for access to Internet and work). My intention was to allow Full Control to both on my Data-partition. Initially the setup was ok, just that any files created by my Computer Administrator account could not be shifted (when tidying up my folders) by my limited account.

Now I am left with Full Control of my Computer Administrator account, when I am logged in there. I have added the limited account to the User names section in the Security tab for the partition, and given Full Control. In Advanced it tells me: "Apply to: This folder, subfolders and files", which is the same as for the Computer Administrator account, and should be ok.

However, logged in on the limited account, I can view the subfolders of the partition but for their content I get an "Access denied" message. Whatever I did wrong with playing with the "Replace Permission on all child objects..." I now just want to get back to the original setting, which was cumbersome, but worked.

I thought of two options:
1) Change the limited account to a Computer Administrator account, and after a restart back to a limited account.
2) Create another limited account and shift or access the data, then delete the old limited account.

Whilst the latter might be the "easier" option, could someone explain, whether the first option would work, or wether the second option might not work.

Thanks very much in anticipation.

Shorsh

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How to: Set Share Permissions for a Database

by Peconet Tietokoneet In reply to How to rectify messed up ...

http://msdn.microsoft.com/en-us/library/ms181068%28VS.80%29.aspx

Collapse -

Re: rectify messed up Share permissions

by Shorsh In reply to How to: Set Share Permiss ...

thanks Peconet,
but I wanted to know how to get the original share & security permissions back for a limited account to access a shared partition.

any help for this is much appreaciated.

Shorsh

Collapse -

It will be hard to say......

Because of your setup it will be hard to say how. What ever you have done, you should of made a note of it or at least have a restore point that you can go back on. Surely with your server software there should be some sort of system in play for you to reverse your settings. If you did not do any of the the above then it will be hard to give any answer to your problem. The only way is to do it from fresh, but this time make a note of what you are doing so that you can go back and do a reset or edit the settings.
Plus, get to know your server settings in and out, find out what the settings mean, get a good book on the server in question.
Sorry i can not add any more info to your problem.

Collapse -

will research first...

by Shorsh In reply to It will be hard to say... ...

Thanks Peconet, I'll have another go with a different account. changing the limited account to computer administrator worked, but when I switched it back, it had the old permission settings.

Shorsh

Collapse -

Share permissions detected

by Shorsh In reply to Re: rectify messed up Sha ...

i should have checked over what I've done in the first place: I changed the security permissions and messed with these. However, I diodn't change the share permission on my data partition.
So, now since I changed these to Full Conrol for both accounts and removed the Everyone (Read), I can access the partiton with no probs.
I think it was the Share Permission: Everyone set to "Read" which decimated the Security permissions to an effective access only for certain folders, whilst the Creator Owner permissions allowed full caccess to what I created with the ltd account... or so.

Anyway, I can now access all data and the issue is resolved.

Thanks to all for any thoughts.

Shorsh

Collapse -

Nice to know everything is ok....

Good work. Now do not mess it up. :)

Collapse -

This is what I've done when restoring drives/partitions...

by Darryl~ Moderator In reply to How to rectify messed up ...

Quite often, when doing a reinstall or switching computers, I have my data drive set with spicific permissions on various folders....things like the My Documents folder may have only myself with any permissions. We in put that drive in the newly installed OS, I can't access the folder. Now I've done the whole "take ownership" thing & so on but usually there are still some files that I still get that "Access Denied" message on....plus, the old accounts are still listed under the security permissions & they have to be deleted.

So this is what I do now....

On the root of a drive I <u>know</u> has the permissions I want to transfer to all the files/folders on the "messed up" partition/folder/etc....I create a new, empty folder & I tell it to inherit all permissions from the parent folder & check the box to apply to all child objects too.

On the partition/folder/etc I want to reset permissions on...I take ownership & remove all permissions from everyone (so there are no accounts listed) & apply that to subfolders (don't inherit permissions from parent)....then add yourself as having full permissions & apply to all child objects.

Move the contents to the "newly created" folder that you gave inherited permissions to on the root of the drive you know has the proper permissions.

Once all files are moved, take ownership of the "new folder" (if not already done) & verify that the permissions have propagated down through all folders....if not, clear all accounts from the root of the new folder applying to all child objects but THIS TIME make sure you check the box to inherit from the parent object.

Your permissions should be reset & you now should be able to customize the permissions & move the files to the desired location.

Back to Hardware Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums