Question

Locked

How to stop background windows from becoming active

By johnself ·
There must be a simple solution to this, but I haven't been able to figure it out.

It drives me nuts. I'll be working on something (e.g., IMing, on Skype, writing a paper) and all of a sudden some background program will become active and automatically move to the foreground.

It is especially frustrating when I'm having conversations with people.

I don't really understand the point of having this feature anyway. I know the background program is open. I opened it and if I want to use it I will click on it. I DO NOT need it to become active when I'm working on something else.

I do a lot of multi-tasking and this happens to me ALL the time and is incredibly annoying. I do not remember this problem in XP. Something seems to have changed in Vista.

I know in the general scope of things it's not a huge problem, but it is very bothersome.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Certain key combinations can do that........

by ThumbsUp2 In reply to How to stop background wi ...

You may have set them without knowing you've done it. For example, in XP if you press ALT+TAB, you can cycle through the open windows, bringing each to the front. You may be pressing the exact key combination while IMing to bring up another window.

You might also check those background applications to see if the auto-save feature is turned on. When that's activated, the program becomes the 'active' window and comes to the front.

Collapse -

Also check these Registry settings

by Jacky Howe In reply to How to stop background wi ...

to make sure that they are set as the default.

Press the WinKey + r and type Regedt32 in the Run box and press Enter.

Navigate to HKEY_CURRENT_USER\Control Panel\Desktop

The two registry values are shown in the right hand pane.

ForegroundLockTimeout should have a default value of 200000 (Decimal)

ForeGroundFlashCount should have a default value of 3

Collapse -

Try another

by Jacky Howe In reply to Also check these Registry ...

Keyboard and Mouse.

Collapse -

You don't have to apologise

by Jacky Howe In reply to Try another

It's the site playing up when that happens. If it happens again open My Workspace, Forum Posts and check Questions Started.

Collapse -

Stopping windows from stealing focus:

by CaptBilly1Eye In reply to How to stop background wi ...

Whereas XP had TweakUI, the Power Toy from Microsoft that provided an easy way to 'stop windows from stealing focus,' Vista provides no such option either built-in or through an add-on app. I have heard from some Vista users that the TweakUI for XP tweak to stop focus stealing will work in Vista.

<i>NOTE: Before making changes to the Registry, make a backup of the Registry.</i>

Here is the registry key change that occurs when you use the option to 'Stop Windows From Stealing Focus' in XP using TweakUI:

the value for the key -
<b>HKEY_Current_User\Control Panel\Desktop\ForegroundLockTimeout</b>
is changed from 0 to 30d40
(the base value is hexidecimal)

Try making that simple Registry edit to see it it resolves the issue.
.

Collapse -

Thanks

by johnself In reply to Stopping windows from ste ...

Thanks for your suggestions Jacky Howe and CaptBilly1Eye, but the registry settings already had those values. It must be something else.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums