How to stop Belkin 802.11g Wireless Router from Dropping Connection

By davewigley ·
Im having problems with my home network. I am broadcasting my SSID in a built up area, and set my (2) PCs to connect wirelessly to it. However, the connection seems to drop on a regular basis and usually requires a manual repair (via windows) on the connection to get it back. I have tried changing the channel that the router broadcasts on and also tried stopping the Wireless Zero Config service, but these dont seem to make a difference. I want to get the PCs to stay connected to my network for the duration that they are on. Can anyone help?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

There are any number of possibilities here

by HAL 9000 Moderator In reply to How to stop Belkin 802.11 ...

But the most likely one is that the WiFi router is getting drowned out by some other WiFi appliance like a Cordless Phone, Mobile Phone, Repeater station for TV, Radio, Microwave link or just about anything else in the RF Spectrum that while not necessarily on the same Band will if powerful enough just drown out any connection.

It's also possible that if you haven't instigated any Security on the system that some one is playing Silly Buggers with you and causing the system to drop out when there is traffic on it or it could just be a faulty unit that is breaking down under load and needs replacing.

Have you applied the latest Firmware available and changed the Default Password?


Collapse -

Firmware is updated and password changed

by davewigley In reply to There are any number of p ...

Thanks for your quick response HAL. I have checked the firmware is up to date and the password is different from the default setting. I was wondering if not broadcasting the SSID would help with this problem (or is it just a more secure way to connect?). Also, is there a way of configuring XP to only connect to my network? It seems to drop off mine and pick up others in the street (which are also Belkin) - I only have my SSID in the list of recommended wireless networks (in the wireless network config settings). Its interesting what you said about the other wireless appliances interfering with it, even if they are broadcasting on different frequencies, but not much I can do about that. Is this why changing the channel makes no difference?

Collapse -

If you are being flooded with RF

by HAL 9000 Moderator In reply to Firmware is updated and p ...

There is absolutely nothing that you can do to prevent this from happening short of constructing a Faraday Cage around the inside of your House/Apparent. That will stop the external RF Radiation but none of the internal RF Radiation and as the computer WiFi are very low power they often get swamped by other signals.

However if you seem to be picking up other WiFi LAN/s I would suggest that you employ WEP/WAP depending on what your WiFi Access Point accepts and that should prevent the problem also cut out the SSID broadcasting as well.


Collapse -

Change your brand

by jlwilliams In reply to How to stop Belkin 802.11 ...

I had the same problem with the Belkin product(s). I have no idea why, I tried the same solutions you did to no avail. I simply took all the equipment back to the vendor and replaced it with Linksys, problem solved. Good luck.

Related Discussions

Related Forums