Question

Locked

How to stop disk conversion at next reboot

By milancas1 ·
Hi
Wondering if somebody can help me.
Is there any way how to stop disk conversion at next system reboot after executing command convert c: /fs:ntfs?
Basically I have FAT32 partition on my XP Pro PC and decided I don?t need it anymore so I ran convert c: /fs:ntfs command. Obviously C drive was in use and it will run conversion at next start up. Is there any way how to stop it as I actually still need FAT32 system? Maybe registry change or commands like Diskpart od Fsutil?
Any help much appreciated.
Thanks

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well...

by seanferd In reply to How to stop disk conversi ...

Since it seems that there are no prompts at all after rebooting where you could stop this, the only way you can be sure it won't happen is to boot from a live OS on CD/DVD or Flash drive that has registry editing capabilities. Possibly even a Window install/recovery disk that gives you access to the recovery console.

Or, if you slave the drive into another computer, and you can then load the registry hives into an offline registry editor.

I'm not entirely sure where the command would be found, possibly under one of the Run keys, Boot Execute, Scheduled Tasks, Winlogon, or Logon type entries.

For example:

HKLM\System\CurrentControlSet\Control\Session Manager\BootExecute

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

HKCU\Software\Microsoft\Windows\CurrentVersion\Run

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Taskman

Collapse -

OK, here:

by seanferd In reply to How to stop disk conversi ...

HKLM\System\CurrentControlSet\Control\Session Manager\BootExecute

remove the entry

autoconv \DosDevices\C: /FS:NTFS

and you probably want to replace it with the normal one

autocheck autochk *


If your system has already been shut down, you'll need to boot into Recovery Console and edit the registry from the command line.

From the command line, you could do it this way:

reg delete HKLM\System\CurrentControlSet\Control\Session Manager\BootExecute /va

Which will delete everything under BootExecute, in this case the convert entry.

When you boot normally, you should put the autocheck entry back via Regedit.

Collapse -

Thank seanferd

by milancas1 In reply to OK, here:

you're a star

Collapse -

Hope it helped

by seanferd In reply to Thank seanferd
Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums