Question

Locked

How to stop number be presented as a phone number with Skype actions?

By Healer ·
My HTML web page has a number of 9 digits. It works okay when tested locally on IE8. After uploading to the hosting server I tested the same page again. All the phone numbers including the 9-digit number which is not a phone number are all presented as phone numbers with "Skype actions" symbol. It does not happen on Safari, Firefox, or Chrome, probably because I don't have the Skype enabled on them. However, how can I tell the browser that a number is not a phone number? Is there something I can do on the code to prevent it be presented as a phone number?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this out.....

See the Skype button on the Internet Explorer it has a "Remove Skype add-on for Internet Explorer" action on it.

If you don't see the button you can remove the feature by disabling the add-on. That is done under the Tools menu in Internet Explorer.

There is an Options dialog in the first screen of the full installer that allows you to choose which components you want to install.
The the upgrade installer that you download from the Help menu or when being prompted to upgrade doesn't have this dialog,

After installing the toolbar they have attempted to make it obvious to you that they have done it in two ways:

* There is a final dialog window in the installer informing you about this integration with your browser
* The next time you start your browser it opens up to this page http://www.skype.com/intl/en/help/guides/ie_addon/?lang=en. It only happens the first time so it is possible to miss it, of course!

Both toolbars have the options to disable or uninstall them highly visible so if you don't like it they attempted to make it easy to un-install also. The web add-ons will not be installed by default the next time you upgrade on that computer.

Hopefully this helps you out with your issue.

Collapse -

Reponse To Answer

by Healer In reply to Try this out.....

Thanks for the input.
I am not concerned about me having the Skype add-on with the Internet Explorer as a user. I am concerned about other people reading my web page using the Skype add-on as a user. The Skype add-on seems to indicriminately present a string of digits as a telephone number regardless of whether it is actually a telephone number. I have supposed there might be some html code to tell the Skype add-on on a browser that certain strings of digits are not telephone numbers.

Collapse -

You'll have to find out why itn does that.

by seanferd In reply to How to stop number be pre ...

I rather imagine it is poor coding in the add-on itself.

But what about adding non-breaking spaces to the beginning or end of the number? Or http://www.frontpagewebmaster.com/m-386505/tm.htm ?

Probably some hints here:
http://developer.skype.com/accessories

Collapse -

Reponse To Answer

by Healer In reply to You'll have to find out w ...

I googled and found adding the following inside of the number (a string of digits) would prevent Skype from presenting the number as a phone number. I have tested it and it worked well.

<span style="display:none;">_</span>

Collapse -

<span style="display:none;">_</span>

by Healer In reply to How to stop number be pre ...

I added the above snip of code in my reply above. For some reason it didn't show up. Also this new format would not let me go back to correct or change either. What a shame!

Collapse -

Indeed!

by seanferd In reply to How to stop number be pre ...

The Q&A format is certainly odd and inflexible.

The span style is a great idea - much less work involved than encoding the numbers and easier to maintain than coding spaces or dashes.

Good to see you found a workable solution.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums