General discussion

Locked

How to Stop Relay on Exchange 2000

By saaedb ·
I have my exchange setup, but there are people who are relaying through the exchanger, which is choaking alot of our bandwidth.
I'v tried by unchecking the allow annonymous box, but that then denies us to recieve mail from an external network, i'v tried to add allow only the list below check box, but then that stops POP and does not let the MAC's on the network to send and receive mail.
Is there any viable solution,so i can stop people from relaying through my Mail Server, and have a happy Exchange that will let us do POP and External Emails :-).
Thanks
Saaed

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ChrisDent In reply to How to Stop Relay on Exch ...

Last time I checked Exchange 2000 didn't relay by default. Still... worth checking this lot.

Go to the System Manager and to the the properties for the Virtual SMTP server.

The information you need is under Access.

Authentication has to be anonymous if you want to recieve e-mail from external sources.

Connection should be "All except the list below".

Relay should be set to "Only the list below" (which is then normally empty.

At the bottom however is the "Allow all computers which successfully authenticate to relay, regardless of the list above."

Now here is where it gets complicated. If that is all set and you're still getting e-mail relaying through then you have a problem.

First of all check whether your server really is an open relay or not. To do that follow these steps.

From any machine enter the following commands:

telnet <mailserver> 25
helo
mail from: <any e-mail address>
rcpt to: <any other external address>

At this point the server should respond:

550 Unable to relay for <external address>

If it allows that mail through then you have an open relay which needs to be fixed so check for patches etc etc.

If that mail won't go through then your server isn't an open relay, but you have another problem. If people are bouncing e-mail through the server its possible that one of the domain user accounts has been compromised.

At which point you can either change all the passwords or turn on logging and start digging.

Collapse -

by saaedb In reply to

Poster rated this answer.

Collapse -

by hitchcock4 In reply to How to Stop Relay on Exch ...

The responder in Answer 1 stated:
At the bottom however is the "Allow all computers which successfully authenticate to relay, regardless of the list above."

This checkbox should be unchecked if only MAPI clients (used by Outlook) are connecting. It is preferred that this is unchecked.
If some users are using other mail clients that use POP3 or IMAP, then this should be checked so that they can access their mail in that fashion.

When you are done with all of these settings, restart the service for "Simple Mail Transport Protocol" (and may need to to also restart "MS Exchange Routing Engine").

Collapse -

by saaedb In reply to

Poster rated this answer.

Collapse -

by saaedb In reply to How to Stop Relay on Exch ...

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums