General discussion


HP PSC 2210 takes too long..

By an_it_guy ·

I have been using PSC 2210 ALL-IN-ONE unit for past one year without much problems. Suddenly it has started behaving very strange! It has started taking tooo long to respond to whatever it is 'told' to do.
Like, it takes almost 4-5 minutes before printing every line!
Nothing has changed on my PC. I tried disconnecting it altogether from PC; with just power-cord connected; then tried using its "COPY" feature. It inititiated.. but it was taking over 20 mins to complete this 'COPY' of one A4-size test page!!!
I checked HP site for any updates.. downloaded a firmware for this model and updated it.. but it did not solve the problem. Not sure what went wrong.
Any suggestions? Any idea how to 'bring it back to life' ?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ptreadway In reply to HP PSC 2210 takes too lon ...

I had the same problem with a canon printer,what they told me to do was pull the printer head and clean it with a alcohol swab.Cleand it with a swab and Q-tip,works like new.

Hope this helps.

Collapse -

by an_it_guy In reply to

Hey buddy.. thnx for your reply. I already got it working, and maybe the same logic applied.
In my case, I replaced both the cartridges (black & color) - and the printer started working normal.
Still it is amusing how is that related to 'delayed-printing'!!
Nevertheless, thanks for your hints. Cheers.

Collapse -

by an_it_guy In reply to HP PSC 2210 takes too lon ...

This question was closed by the author

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums