Question

Locked

htmed.dll error during MS Service Pack 5 installation

By octavia_biris ·
While installing MS Visual Studio Service Pack 5, I got the error message "htmed.dll was unable to register itself in the system registry", after which installation was not successfully completed. I installed the service pack after installation of MS Visual Studio 6, during which I encountered a "Setup Was Unable to Create a DCOM User Account" error, which caused unsuccessful installation of MS Visual Studio 6.( I managed to address the DCOM error by re-installing Studio 6 without the Visual Studio Analyzer.)
De-installation of MS Studio 6, erasing of remaining htmed.dll files, and subsequent re-installation of MS Visual Studio 6 and Service Pack 5 did not remedy the htmed.dll error. Is there anything else I can do?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this first

by IC-IT In reply to htmed.dll error during MS ...

Open a cmd prompt and type
regsvr32 htmed.dll

Collapse -

regsvr32 - you may need to mention path

by BizIntelligence In reply to Try this first

To register a file command can be:

regsvr32 "path of dll file"

To un-register a file command can be:

regsvr32 -u "path of dll file"

Cheers !

Collapse -

that does not work. either...

by octavia_biris In reply to Try this first

Thank you for your quick responses. I applied the regsvr32 command on the path of the htmed.dll, amd I got another error message, saying "DllRegisterServer in htmed.dll failed. Return code was: 0x8002801c". What should I do next?

Collapse -

Likely registry permission issue

by BizIntelligence In reply to that does not work. eithe ...

It is likely that permissions on part of the registry have been changed to deny you access. You will need to be a local administrator to register the COM object. You have to local administrator to install that software. If PC is part of windows domain then unplug it from network and login as local administrator and then install. If it fails again then read following article to see how you can use regmon utility (freeware by System Internals) which registry item is failing to open.
http://www.cryer.co.uk/brian/windows/trbl_nt_rgsvrfld8002801c.htm

Good Luck !

Collapse -

Are you running Vista?

by Str8thru In reply to htmed.dll error during MS ...

Assuming you are, are you installing the program by selecting "Run as Administrator"

check out the site below for another option

http://social.msdn.microsoft.com/Forums/en-US/vblanguage/thread/763a9ee4-7231-4fdb-b2ea-f5426aac2ae2

good luck

Collapse -

registry key permissions

by jconnell In reply to htmed.dll error during MS ...

I found that the write permission of registry key HKCR\Interface\{34A715A0-6587-11D0-924A-0020AFC7AC4D} had been blocked. When I allow write of this using regedt32 I could properly install SP5. I diagnosed the problem using regmon from http://technet.microsoft.com/en-us/sysinternals/bb896652.aspx with "Options / Filters / Log writes" as suggested at http://www.cryer.co.uk/brian/windows/trbl_nt_rgsvrfld8002801c.htm

Collapse -

This worked for me too

by ktredget In reply to registry key permissions

Thanks for your post jconnell - that solved the problem for me too.

Collapse -

This works for me

by the_vulture In reply to registry key permissions

You may want to search for "htmed.dll" in your registry; mine was under a different key.

Thanks,
V

Collapse -

registry keys permission for htmed.dll

by dana777 In reply to htmed.dll error during MS ...

Thanks alot--this also worked for me, I did a regedt32 to edit the registry keys permission, and then searched on 34A715A0-6587-11D0-924A-0020AFC7AC4D key that was suggested above as the culprit... and then sp5 was successfully installed.

Thanks Jconnell, thanks Octavia

Dana Peters

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums