HTTP 405 Verb not allowed

By info ·

I need some help. I am trying to configure my server for OWA, when i enter UN & PW on the logon screen I receive the following message.

The page cannot be displayed
The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.

Please try the following:

Contact the Web site administrator if you believe that this request should be allowed.
Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
HTTP Error 405 - The HTTP verb used to access this page is not allowed.
Internet Information Services (IIS)

Any ideas anyone?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by rotellal In reply to HTTP 405 Verb not allowed

Did you ever get a solution to this as i am having the same trouble now as well. any help appreciated.

Collapse -

You need to allow POST on server

by seanferd In reply to HTTP 405 Verb not allowed

add the verb to

Collapse -

Maybe even dynamic vs static problem????

by ThumbsUp2 In reply to You need to allow POST on ...

One post in an article I found said this:

A 405 error happens usually when you try to POST to a URL that is considered
static by IIS. Thus, I'm suspecting that whatever URL you are trying to
access is not configured to be dynamic -- It seems that you have not enabled the scripting support in hosting setup.

Another article I read said something about putting a slash (/) at the end of the URL causing the problem (it expects a verb) and there was a patch available for that problem.

Collapse -

Very well could be

by seanferd In reply to Maybe even dynamic vs sta ...

What I saw was that factory defaults had few verbs set, so it needs to be enabled. Also that sometimes GET is set, rather than POST, which is generally a bad idea and may not work in this situation. Any of these may apply here,AFAIK. Which ain't very far.

Related Discussions

Related Forums