General discussion

Locked

http access to cisco switch

By kamal.yadav ·
How do you setup C2950 for web access. i have already downloaded the tar file and enabled -ip http server-.
i want to give less than level 15 access to some network admims who can look at port settings on cisco swithces thru web interface and make changes to port speed and duplex

thanks

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by mshavrov In reply to http access to cisco swit ...

You shouldn't just "download" the TAR file - you should INSTALL it. Use the following CLI command to install the WEB interface:

archive tar /xtract tftp://<TFTPServer>/<C2950xxxxx.tar>

If you copied the TAR file into your switch, then, most likely, you do not have enough memory to install (unpack) the content. Prior to installation you should delete TAR file.

After you have your TAR file extracted, you should be able to get the web access to the graphical interface.

If you want to give different levels of access to your admins, you should either create local user accounts with a different "level access", or configure RADIUS/TACACS+.

Good luck,

Mike
CCNP, CCDP, CCSP, Cisco Voice, Security+, etc.
http://www.ciscoheadsetadapter.com

Collapse -

by mshavrov In reply to

Default authentication for HTTP is "enable" password. You may change this by the following command:

ip http auth local

or

ip http auth tacacs

Also you may telnet into your switch, and do "debug ip http auth" to see what's going on when you are trying to authenticate through the Web.

Collapse -

by kamal.yadav In reply to http access to cisco swit ...

Hi Mike:
i used the commad archive and extraced the tar file. using the ip http authentication enable, i can use web interface with secret password ( level 15 access) . i cannot do this with local username/password combo or tacacs+ authentication. one of the configuratuion i tried was

username ky privilege level 7 password cisco
enable secret level 7 cisco1

privilege exec level 7 configure terminal
privilege configure level 7 interface

i am unable to access with this username.
i also tried using tacacs+ configuration ( with checking shell (exec) and privilege 7)
can you throw some light or guide me to a good book on this subject
thanks for your time

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums