Question

Locked

HTTP and HTTPS links not functioning from within applications

By reggiefor ·
Hi --
Sorry for the length of this, but I wanted to supply all of the information that I could. Please read through it all because I know at many points you will think "Aha!" just as I did, only to be disappointed. Thanks so much. Here goes....

I've been trying to help a friend with an annoying problem and after six hours of research and trial-and-error, I am tempted to clean off the hard drive and reinstall everything. But just in case I can avoid this, I'll throw this question out to the many contributors far more savvy than I am....

Scenario: Lenovo desktop running WinXP was working swimmingly until my friend called Verizon about a problem she was having with some email being filtered as SPAM by Verizon.
I have no idea why, but she allowed the Verizon rep to take remote control of her PC and he "changed something". After that, no internet links worked from Outlook Express. She had to swipe and paste the links to her browser. I thought this would be easy to fix --
alas no. I have ruled out its being an isolated OE problem, because much to my chagrin, I also found that if I went into her Verizon Web Mail and tried clicking a link inside of a message, the result was EXACTLY THE SAME as in Outlook Express.

What happens:

Click a link from anywhere other than a web page (i.e. inside of an application, even a Web app apparently), and the "linking" application immediately freezes and goes to a "not responding" state. Task Manager "END" is the only way out. I did notice in task manager processes that "system idle" was at 98% of CPU.

What still works:

One can open a browser and get to specific addresses as well as do searches and click links within IE -- though sometimes even links on web pages freeze up upon clicking.

One intersting thing:

I noticed that when the links aren't going to work, if you right click on them, "OPEN" is not a choice -- only "Save Target As"

I have tried:

1. Going to My Computer/folder options and retyping the ?C:\PROGRAM FILES\INTERNET EXPLORER\iexplore.exe? string in the URL:Hypertext Transfer Protocol file type

2. Start ? Run then typing
regsvr32 Urlmon.dll

3. Set program association for protocols HTTP and HTTPS to IE

4. Made sure IE was set as the default browser. I unset it, then reset it.

5. Several other things that were more desperate than educated attempts to fix this.

Any suggestions? I think the clue lies in the fact that "open" is not a choice for the link; but I can't find the change that this signifies was made.

Any help or advice is welcome.
Thanks for listening.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Did you...

by tmalo627 In reply to HTTP and HTTPS links not ...

check the file association for URL's?? From what I understand, that's what you did for HTTP and HTTPS. But just in case we're talking about something different, Control Panel > Folder Options > File types and scroll down to URL's. Make sure those are set to open with IE.

Hope this helps.

Collapse -

Yes, I set the URL Folder Option

by reggiefor In reply to Did you...

I guess I didn't articulate that very well; but I did that, too. Sigh.

Collapse -

How about

by tmalo627 In reply to Yes, I set the URL Folde ...

downloading the setup file for the version of IE you are using and trying to reinstall or repair the installation of your browser?

Collapse -

I'll try that

by reggiefor In reply to How about

Funny, I just came across a reference to the "browser repair" option right before I got your post. I'll have her try it and post what happens. Thanks.

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums