HTTPS only?

By ross.a.sims ·
I have a Windows XP SP3 computer that I have recently wiped clean and restored. I've performed all of the updates and surfed online with it with no errors. Recently though, I can only access secure (https) sites. Whenever I try to access a regular (http) site, I get a standard 404 error. Thanks for any help.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Try drooping your IE Security down

by OH Smeg Moderator In reply to HTTPS only?

Sounds like you have it set too high and it's only allowing you to access Secure Web Sites.


Collapse -

Didn't work.

by ross.a.sims In reply to Try drooping your IE Secu ...

No, I've tried that. I've tried taking the security levels all the way down and it doesn't do anything. I've also tried turning off firewalls, and I've done an IE 7 reset. None of that worked.

Collapse -

HTTPS only

by Nimmo In reply to HTTPS only?

You didn't mention which browser you are using so I am going to assume that it's IE.

If the above suggestion doesn't work try resetting IE to default.

You could also install a third party browser and see if you can access normal HTTP sites.

If you can access normal HTTP sites via a third party browser then it's an IE problem, if you can't its something else.

Try resetting the TCP/IP stack: run>cmd>netsh int ip reset.

Collapse -

IE 7

by ross.a.sims In reply to HTTPS only

Ok, I am going to try a copy of Firefox 3.03 and I'll also try resetting the stack. I'll let you know how it goes. Oh and I'm using IE 7, should've mentioned that, sorry.


I've tried installed Firefox, to no avail. I get a connection interrupted error from there. I can access HTTPS websites from either Firefox or IE though. Resetting the Stack didn't do anything either. Thanks though.

Collapse -

What software did you install?

by IC-IT In reply to IE 7

The usual suspects are;
Firewall XP and any third party.
Expired or incorrectly set Anti-Virus/Internet Security suites.
Unpatched Zone Alarm.
VPN client

Bad IE7 setting - go into your internet options settings in the control panel, Connection Tab, Lan Settings and make sure "use Proxy server" is UNTICKED

Collapse -


by ross.a.sims In reply to What software did you ins ...

I killed the Firewall first thing.

The Antivirus can't update either, I'm using AVG 8.0, and I did a standard install with it.

No Zone Alarm on this machine.

We use Novell Client, but once again, I did the standard setup, which has never caused an issue before.

I put all of these programs on this machine and tested it in my office, before moving to location. It worked fine in the office. On location, after I left the machine (which means people could have gotten to it and done something), it started with the 'HTTPS only' thing.

I've also installed Firefox 3.03 recently and it is doing the same thing.

I will check that IE Setting, but I'm pretty sure that the Proxy server is unticked.
Thanks, I'll update to let you know.

Collapse -

RE: no http

by Nimmo In reply to Software...

If you haven't checked already open IE and click on tools>internet options>connections>remove any dialup or VPN connections then click LAN settings> un-checked all boxes.

Collapse -

Easy Fix

by SFredz In reply to HTTPS only

Reset your advanced internet options to their default settings and BINGO

Collapse -

You may be a victim of the AVG8 update bug

by Jacky Howe In reply to HTTPS only?

There is a fix here see if that helps
Inactive components and/or blocked internet connection after update to 8.0.196
<i>Keep us informed as to your progress if you require further assistance.</i>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.

Collapse -

HTTPS only solution for me

by reedbr In reply to HTTPS only?

User had a virus on his PC. Symantec Endpoint Protection detected and cleaned it, used MalwareBytes as well. HOSTS and LMHOSTS files were deleted in the process. The only risidual effect was that HTTP would not connect. Ping was OK, DNS was OK, HTTPS was OK, FTP was OK. Local admin user (different profile on the PC) worked fine on HTTP. The last time this happened on supported PC here, I deleted and recreated the users profile. Didn't want to do that again. Came across quite a few threads with users having similar problems but no solutions. Finally found one specifically after cleaning a virus, proxy server was enabled when they weren't being used. Disabled and HTTP works:

IE/Tools/Internet Options/Connections/LAN
disable Proxy

Found it in a post from Blaine B in this thread:

Related Discussions

Related Forums