I can not see my server from my PC but I can see my PC from my server?

By jccox3 ·
I have a windows SBS 2003 and have recently replaced the network card. Since i replaced the card I can not see the server from any of my windows XP workstations. I have DNS and DHCP running on the server. I have accounting software that runs on an SQL server and there is no problems with connectivity. Any suggestions?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

on a test machine

by ---TK--- In reply to I can not see my server f ...

you could try a couple things, clear the ARP cache (

and or run a DNS flush ipconfig /flushdns

Just a starting point, it might help...

Collapse -

Static IP?

by oldbaritone In reply to I can not see my server f ...

Does the server have a static IP? Is it the same IP it used to be with the old NIC? Windows gets ornery about re-using a static IP on a different card, I know. You need to delete the old NIC device, which isn't easy to do. You can ignore the warning, and that will be OK, as long as you don't plug the old NIC back in.

Sometimes, someone has put entries in the HOSTS files of the workstations. Other times, they may have referred to a share using the IP address rather than the server-name. (if Server-x's IP is, then you may access either \\Server-x\share or \\\share to get to it.)

Another thought - have you checked the firewall rules for the new NIC? They don't propogate automatically, so file sharing, ICMP and other things may not be allowed through the new NIC.

Collapse -

Seems to be working

by jccox3 In reply to Static IP?

I went in and did the ARP Cache and the DNS flush. Right after that I went in to check on my firewall. I could not open my firewall because another program was accessing it. So I went in to Routing and remote access, and under NAT/Firewall settings and I had to turn on Address assignment and name resolution. Which is my lack of knowledge, I assumed when I restarted the DNS and DHCP servers it would automatically work.

Related Discussions

Related Forums