i can ping but no aplication can use internet

By ahmadi3d_ali ·
my system was infected and was downloading and uploading on its own! i installed all kind of anti virus and programs and finally i deleted the virus !
now when i connect to connection i can ping all sites!
but all my browsers (Opera , Chrome , fireFox , IE) give me error after trying to open a site!
also my skype and all other aplication do the same!
my internet download manager think im not connected !
i tryed giving DNS manually and i checked all options ! i tryed restarting all services and ..
i dont have restore point! so dont say restore it!
and i dont want to install another windows!
it seem that the antivirus deleted some important file that were infected! ( i used Rescue mode BitDefender )
and now there seem to be problem !
is there anyway to fix this or repair the windows? i used Microsoft Repair Windows but ... it didnt work!
i also tryed SFC\scannow but ...
and entering IP doesnt work either! (like enter the IP for google in browser not the adress )
im getting crazyyyyyyyyyy! please help me!!!!!!!!!!!!
System Properties :
Windows 7 64bit
internet network : (i use a Lan to connect to my Modem and i make a connection (Broadband) to connect the ISP!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

have you considered

by PurpleSkys In reply to i can ping but no aplicat ...

backing up your important stuff and just reloading windows?

Collapse -

Reponse To Answer

by ahmadi3d_ali In reply to have you considered

as i said before i have programs and some important stuff that cant be back uped!
so i cant install another window!
please only guide me through solving my problem

Collapse -

Have you tried doing a TCP/IP stack reinstall/reset?

by robo_dev In reply to i can ping but no aplicat ...

Below link is for older Windows version, but Win7 procedure is similar.

Viruses tend to corrupt registry settings and/or TCP/IP stack driver files, this process fixes all that

Collapse -

Reponse To Answer

by ahmadi3d_ali In reply to Have you tried doing a TC ...

it didnt work!@
i tryed what you said but it doesnt work .. still the same issue!
maybe i should analyse the problem with some tools !!
cause it seem everything is useless and nothing fix it!
do you have any suggestion for analyse program?
thx for your comment

Collapse -

Reponse To Answer

by davidfacer In reply to Have you tried doing a TC ...

I had this problem recently on another computer also infected by virii. How we fixed it was using Registry Mechanic v6.0 - a utility which finds and fixes Registry problems. Any decent Registry problem fixing software may well be able to do the same, and I believe you can download a time limited version from the Internet - if not through your machine, then do so via another. Good luck!

Related Discussions

Related Forums