Question

Locked

I cannot delete a folder from win xp.

By grtfldale ·
I am trying to delete a folder in windows xp pro. When I delete the folder, I get an "error deleting file or folder" message, with "Cannot delete (file name); The file name you specified is not valid or is too long. Specify a different name.
Turns out I wound up with an empty file in a file in a file.....etc... Lots of files, all empty. I renamed the primary folder then subfolders with no luck. Attempts to delete lower folders (sub) unsuccessful.

Did research, regained ownership of file with no luck. Attempted to delete in command prompt,with no luck. Nearly every command I make in command prompt gives me this message: "The system cannot find the path specified". Viewed Microsoft Article I 320081: You cannot delete a file or a folder on an NTFS file system volume. Followed all instructions, no luck. Tried Unlocker, though it often said it had deleted file, nothing changed. Tried Gipo - moveonboot, no luck. According to unlocker, there is no hold on the file. I would really appreciate any help anyone has.Also, the command prompt"The system cannot find the path specified". I would appreciate any clarification. I checked microsoft, technet, never anything related to a situation like mine. Thanks in advance.

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

See if this will help

by Jacky Howe In reply to I cannot delete a folder ...

Example

You are going to have to find the first 6 letters of the File Names. Create a Batch File and name it the Username.
===============

dir /s /a /o /b c > allfiles.txt

===============

Take the first 6 letters of the Long File Names and add ~1

zaptec~1

Modify your Batch File to suit

del zaptec~1.* /s /q

Collapse -

Jacky has the better solution. (nt)

by seanferd In reply to See if this will help
Collapse -

LOL

by Jacky Howe In reply to Jacky has the better solu ...

folders not files. Anyway same principle but maybe rd zaptec~1.* /s /q

Collapse -

A solution, several possible causes.

by seanferd In reply to I cannot delete a folder ...

Solution:

Can you drag part of the subfolder tree out of the top-level folder, or the next level down? This will shorten the file names so these can be deleted.

No?

Get a live CD of another operating system - perhaps UBCD will work, Knoppix has always worked for me. (I can give rather detailed instructions for Knoppix.) The upshot is that you need an offline OS that can read NTFS partitions. (Of course, some live OS can be booted from a USB flash drive as well.)

You boot the Live CD, access your hard drive, and delete the file this way.

Causes:
There may have been an extended character in the file name, especially id it was created by a software app.

It may have been that the folders were nested so deep, that the full path to the file is too long, resulting in a violation of file name length limits. (I've seen software do this as well.)

Collapse -

You should

by Jacky Howe In reply to A solution, several possi ...

be able to do it with Knoppix. Possibly from a command line. I'm outa my league there though.

Collapse -

It has worked for me at least once

by seanferd In reply to You should

possibly by simply keeping the installed OS out of the equation. (But why then can NTFS4DOS read files with illegal-length names? Hm...)

My brother could not defrag his drive because a file name was too long, it turned out. It was some stupid thing Yahoo! software (came with the ISP's install disk) deeply nested in Documents and settings. Windows would not delete it, so I took it out with Knoppix. No command line environment necessary. Mount the drive, if not auto-mounted, then allow write access (turned off by default for safety). Browse to file/dir and delete.

Can't say it will always work, if no NTFS software can access it. But why can the situation even occurr in the first place? Slays me.

Collapse -

Its folder is eliminated. Thanks!

by grtfldale In reply to I cannot delete a folder ...

I really appreciate the help. I was able to delete the "folder" (sometimes this hits me like the "i" before "e" spelling rule...a careless communication error. I was pursuing the batch file fix when I realized its been a long time since i had done any. After some research, I pursued the "move folder up several levels" fix. Initially I couldn't move anything, but I could move folders with "unlocK" (though it wouldnt delete them). After about 5 moves (with a few moves that didnt take), I was able to completely remove that son - of - gun. I didnt pursue the Knoppix.
I cant believe these thiings still happen. The guy on tv promised me that Windows 7 wont have the same problems as: vista, xp, millenium.......
Thanks again

Collapse -

Glad you got it sorted out {nt}

by Jacky Howe In reply to Its folder is eliminated. ...
Collapse -

The 'problem' Windows 7 was having is called ...

by OldER Mycroft In reply to Its folder is eliminated. ...

Input Error - either Software-driven or User-driven it matters not. Put simply, any file residing within a deeply deeply deeply nested directory structure, will eventually reach a sub-level that the OS just can't handle.

Collapse -

Glad something helped.

by seanferd In reply to Its folder is eliminated. ...

I like your variation on the methods offered.

Back to Windows Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums