General discussion

Locked

I cant get my port to open! Please Help!

By thedrummer2006 ·
I have just installed a new antivirus suite for my windows 2003 domain controlled network. This software requires port 9959 to be open on both the server and the clients. The windows firewall by default disables all ports.

I have setup an exception in the windows firewall to allow this port to open and I have made sure that I have no group policy settings causing conflicts but I cannot get access through this port.

My software distributor suggest that I try to telnet into each pc to port 9959 to verify that the port is open. I can connect to port 9959 on the server from the clients but not the other way around.

Please help! I have exhasted all efforts.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Probably a dumb question..

by BFilmFan In reply to I cant get my port to ope ...

Did you follow the steps as listed in http://support.microsoft.com/default.aspx?scid=kb;en-us;308127

Did you enable both TCP and UDP?

Collapse -

Yes!

by thedrummer2006 In reply to Probably a dumb question. ...

Yes I did! Still nothing.

Collapse -

update the firmware of the router.

by X-MarCap In reply to Yes!

If your using a D-Link I had to update firmware to current, and then it was OK...

Collapse -

Thats not it

by thedrummer2006 In reply to update the firmware of th ...

I am running 4 different types of NIC's.

Collapse -

Same Problem for Command AntiVirus ESP Enterprise

by ayurcek In reply to I cant get my port to ope ...

I have the firewall on the client turned off and am still unable to telnet to the client on port 9959.
I am able to use telnet to check port 9959 from the client to the server but not from the server (or any other machine) to the client.

I enabled the telnet service of both the server and the client and was able to telnet the regular way (port 23) but not port 9959 to the client (yes I know that I will not actually get a logon for port 9959 but the window should say 'telnet' at the top and the cursor should just blink if it is successful).

Has anyone solved this problem?

Also, I think we all know that the ESP program is not actually using telnet but just needs to communicate using port 9959 and the tech guys at Authentium asked us to use telnet to check it.
Does anyone know of another way to test port 9959 other than telnet?

Collapse -

write a C program

by X-MarCap In reply to I cant get my port to ope ...

1. open a socket on the port, connect to it and print the errorcode...

s=socket()

ret = connect (port,s);

\\print the connect status.
printf("connect VALUE = %d\n",ret)

\\ close the socket
shutdown (s);

tell me the error number or look it up yourself in the RFQ.

Tim

Collapse -

Problem Solved-Install ESP client software

by ayurcek In reply to write a C program

I think the problem was solved for both Chris and I when we found out that you needed to install the ESP Command Antivirus software on the client so that there was something listening on that port before you could test it with telnet. Authentium does not tell the public this for some reason.

Back to Security Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums