Question

Locked

I can't reinstall my printer driver

By vikkki ·
I unistalled my printer and then i tried to reinstall it fromm the installation cd-rom.When the installation begins it appears a message that says that there is a newer driver already installed and the current installation stops.But my printer isn't recognized.And I don't find the driver that is already installed. Moreover when I go to the device manager the page is blank!!Has this to do with the problem of my printer?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Reboot after de-install (post cleanup may be required)

by cmatthews In reply to I can't reinstall my prin ...

Many printers come with more than just drivers. They come with auto update services, ink monitors, ways and reminders to direct-sell you ink or promote other products or logos. So depending on the installer and your user privilege-level, you may have to reboot afterward.

Device manager: It's possible plug-and-play ops were suspended and it was trying unsuccessfully to reboot when you went into device manager.. but my question would be:
Why didn't you look in Printers and Faxes?

Do a complete de-install and even run a post clean-up utility afterward (such as the basic one provided in CCleaner)

Collapse -

I still can't reinstall my printer .

by vikkki In reply to Reboot after de-install ( ...

I looked in the Printer and faxes and actually I removed the driver from there. But still when I put the installation cd-rom and I try to install the driver appears the message I said. I rebooted every time. As about the device manager , I looked in the Plug and Play and is active. The device manager is blank all the time.The problem with it must have been existed before the printer issue but i hadn't realized. Only after the printer issue I found out that the device manager doesn't work. I also went ( after instruction I found in the Internet, I don't have such profound Knowledge of the system)to the system/enum and tried to check a box in the permissions as I was told , but was not allowed.Where else can I look for this newer Driver that the message tells me that its already installed and does not permitt the installation fromm the cd-rom if not in the device manager?

Collapse -

Try a clean boot

by .Martin. In reply to I can't reinstall my prin ...

http://support.microsoft.com/kb/331796

otherwise, make sure that the printer is not connected to the computer when you try and install the drivers.

if not. have you downloaded the latest drivers from the manufacturers website?

Collapse -

the device manager is a blank page!

by vikkki In reply to Try a clean boot

I tried the clean boot and then tried again to install the multiofunctional fromm the cd-rom but once again it tells me that a newer version of the driver is already installed and the installation stops. I went to the official cite of canon and I downloaded the mp driver that was appropriate. but again during thw installation I received the message : "there is a newer version already installed in your computer".How can I uninstall a driver I don't find neither in the file control panel/printers and faxes nor in the device managerwhich is blank? And why if there is already installed a driver , it doesn't recognize the printer? (which is by the way , multifunctional )

Collapse -

Enirely blank?

by seanferd In reply to the device manager is a b ...

Definitely not a printer driver issue then.

Have you tries System Restore? If this does not help:

You can either do a reinstall of the OS (which one?) or you can check the registry:
HKLM\SYSTEM\CURRENTCONTROLSET\ENUM

Check permissions on this key. The System account must have full control privileges. Either this, or PnP is not really running (check Services).

You may also want to do a malware scan, as I would imagine this being the most likely cause of such a problem. If further complex issues are encountered, I would suggest backing up all of your data, wiping the drive, and doing a complete reinstallation.

Try http://malwarebytes.org for a malware scan. Install, allow it to update. Turn off System Restore (which deletes restore points, so if you want to try system restore, do that first). Run MBAM in Safe Mode (no Networking). If it finds anything, run repeatedly until no results are found.

Back to Storage Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums