General discussion

Locked

I installed RedHat as a server but.......

By Blue screen ·
Installed RedHat version 9 as a server when it boots up i get the shell signon screen, how can i make the GUI come up?

I am new to Linux!

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Toivo Talikka In reply to I installed RedHat as a s ...

Usually if you have installed the GUI or X components, the GUI logon screen will be the default.

Check the file /etc/inittab. One of the lines contains the following if Red Hat 9 boots into the shell logon:

id:initdefault:

The second field is the runlevel. If you change it to 5, your server should boot into the GUI logon, all things being equal.

Collapse -

by Toivo Talikka In reply to

If you are new to Linux you may not know what to do next.

Login as root. You can view the file by typing in the following on the command line, finish with Enter:

more /etc/inittab

You will see the initdefault line on the first page. Press Q to quit.

You can just use the good old vi editor to modify the file:

vi /etc/inittab

Press the downarrow key to get to the line starting with id:initdefault:

Press the rightarrow key so that the cursor is on the top of 3.

Press the Del key.

Press Esc, then i

Type in 5

Press Esc

Type in :wq

This writes the modification to the file and quits the vi editor.

Restart the server:

shutdown -r now

Once the server starts, you should be in business.

Collapse -

by Blue screen In reply to I installed RedHat as a s ...

thanks for the procedure after the reboot the screen says, int: Id "X" respawning too fast disabled for 5 minutes and it repeats itself and does nothing.
what shall i do next?

Collapse -

by Jaqui In reply to I installed RedHat as a s ...

xrespawnning to fast:
uninstal the xserver then re-install.
rpmi -force xfree86
the force will completely overwrite the old installation.
this error happens when the install was corrupted, and is easiest to remove the xserver then re-install it.

Collapse -

by Blue screen In reply to I installed RedHat as a s ...

i am new to Linux so you have to explain to me how to do that, login as root, type this in, etc.

thanks for your help.

Collapse -

by Nico Baggus In reply to I installed RedHat as a s ...

Did you configure the X server?

xfree86cfg needs to be used to do that.
Or you can get a working /etc/X11/XF86Config
file from an equivalent working conputer.

Kind regards,
Nico Baggus

Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums