I need help getting USB ports to work.

By smithjk8 ·
I have tried everything I can find to try but I can't get anything to work in the USB ports. OS is XP sp3 and they are 2.0 ports. I have disabled/re-enabled in BIOS, registry, and device manager. When I disable all the ports in device manager and restart, all the ports show back up but nothing will work in them. There are no conflicts reported, and it is both the front and rear ports. It has a MSI k8mm-v mobo and tech support from MSI has been less than helpful. I have updated all drivers that I can find for it, microsoft updates too. There was a pci card with 1.1 ports installed but I have removed that as it would give a bsod as soon as anything was plugged into it. I am assuming that it has something to do with the pci card but I can't figure out how to determine for sure. I have also seen something about ACPI causing conflicts but when I disable it I get a loop on startup.
Any help is GREATLY appreciated!!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Do the ports work in BIOS setup?

by robo_dev In reply to I need help getting USB p ...

For example, will a USB keyboard work to get into BIOS settings?

I would try running the Windows SFC utility to make sure the USB driver part of your OS is not hosed. Goto cmd prompt and run SFC /scannow.

There are some viruses the stop USB ports from working, so make sure you're virus-free, and you might try using system restore back to when your ports worked, if you have a restore point you can use.

Collapse -

Using ps2 keyboard and mouse to get to BIOS

by smithjk8 In reply to Do the ports work in BIOS ...

The PC belongs to a coworker and I am not sure how long the USB ports haven't worked. So I'm not sure when to restore either. I assume it may have been a while as there was an old two port usb in a pci slot. I have run a few a/v progs and it seems to be clear. I will try sfc next time I boot it up. Thanks for the suggestion.
I tried SFC but since I don't have the installation disk, it didn't work. kept asking for OS disk. I can't even get chkdsk/r to work! Says another process is preventing it, works in read only mode though.

Collapse -

Try safe mode

by robo_dev In reply to Using ps2 keyboard and mo ...

it's troubling if chkdsk won't run, but it should run in safe mode.

If I had to guess, I would say that the OS install on the hard drive is pretty hosed, or there's a nasty virus/rootkit on there.

I would make a backup of the hard drive just in case it's on the way out.

Collapse -

Reading all of this

by OH Smeg Moderator In reply to I need help getting USB p ...

It really sounds as if you need to reinstall the OS. So do you have a Install Disc for this version of XP? If you do I would be using it and rebuilding the system. Or you can try doing a Repair Install as per Method 2 here

Also as suggested above I would test the HDD/s with their makers Testing Utility

Or if they are HDD like Samsung and so on which do not have their Own testing Utility you can use Seatools from Seagate. If the drive fails the first test remove it and retest in a different computer if it still fails the test the drive is on it's way to Silicon Heaven but if it passes the second test you need to look at replacing the M'Board, Data Lead or Power Supply.

Just as an aside this system was not once connected to a Domain where the USB's had been disabled through GP has it? That could explain why the USB Ports are inactive.


Collapse -

Hope this will help... ^_^

by joeny_m In reply to I need help getting USB p ...

The main reasons for USB-port with a yellow exclamation mark in your Device Manager are because you have a USB device that is not working correctly or device driver is not installed correctly. Please try the following suggestions.

1. Faulty USB device may cause USB device to be displayed yellow exclamation mark in your Device Manager,
you may have to remove the USB device that plugged in your system and plug to other system to check if it
work well.
2. Check if this USB device needs more extra power to drive.
3. Right click the USB yellow exclamation mark device in your Device Manager, and select remove it from your
system, then reboot the system to let Windows OS to refind and install working driver.
4. Re-install Windows OS, then install drivers for motherboard.

JUST TRY IT.... ^_^

Collapse -

it may be a setting in the BIOS, a fault on the board, or the OS drivers

by Deadly Ernest In reply to I need help getting USB p ...

You've got some good advice on the drivers and looking into if it is an OS issue. If that doesn't resolve the problem you should check that the relevant BIOS settings are set properly. Most USB settings in the BIOS have a way to set them to be be USB 2 or USB 1 or AUTO - they also sometimes have other settings that restrict what you can use them for. Check these and see how they're set.

Another aspect is that sometimes the USB ports get damaged and don't work. If this is the case the two answers are to check the board for a USB header and attach some USB ports by plugging them into the header, if the case has front USB ports, they are usually plugged into one of these headers (most boards have two, three, or four of them - two ports per header); or plug in a USB PCI or PCI-e card to provide USB services.

Sometimes the USB controller on the board goes faulty (this is extremely rare) and only a USB card plugged into the PCI or PCI-e slot will get around this.

Note: The most common faults are faulty Windows drivers, followed by BIOS settings.

One way to check the USB ports etc themselves is to get a Linux Live Disc and run that. If the USB works for that and not the Windows, then it's a Windows driver issue, if they still don't work it's either a BIOS or port issue.

Related Discussions

Related Forums