General discussion

Locked

IBM PS/2 55 SX Error Message - HELP!

By john ·
Hi,
I have an IBM PS/2 55SX that is displaying an error while booting. The PC beeps twice, displays 161 and 163 on the left hand side of the screen. Across the top of the screen is a large red equals sign, followed by "OK" in a red circle with a line through it, then a white arrow pointing to the right, then a picture of what looks like a simply drawn book with IBM written on it. Can anyone tell me what this means? The only indication I can find online is that two beeps means "system board" but that's not enough information for me. Any help anyone can give will be very greatfully received.

Many thanks
MZ

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Seriously

by JamesRL In reply to IBM PS/2 55 SX Error Mess ...

You have a 14 year old computer.

I may have worked on one of those 12 or 13 years ago, but not since. I remember a bunch of us techs celebrating when they trashed the last one at that employer - we really didn't like them.

Spend $50 and get an older pentium that can run Win 98. Thats a better use of your time than trying to fix an old box which would be near impossible to get parts for.

James

Collapse -

Don't get me wrong, I completely agree

by john In reply to Seriously

..unfortunately there's a mass of information on the hard disk of this machine, around 20 years worth of family tree history, that really has to be recovered. Some of it is backed up, but there's stuff that isn't. How would I get the data off the hard disk? Would there be a way to do this by placing the hard disk in another PC and reading it at all?

Many thank
MZ

Collapse -

Absolutely

by JamesRL In reply to Don't get me wrong, I com ...

And I might add, a 14 year old hard disk by this point in time has well exceeded its meantime between failures (MTBF) or in other words its expected lifespan.

I found a page for you:
http://www.computercraft.com/docs/160.shtml

It might be as simple as a CMOS battery failure - look at the bottom of the page. Replace that first and see what happens - you will need to go through the "automatic configuration setups". Hopefully you have your original startup disks, if not that website has instructions for making them.

If it is a hardware failure like the motherboard or driver controller, you still might be able to salvage the data.

The trick is reading the ESDI HD. Your drive controller in the PS2 is not moveable to a new PC. You would need to find an ESDI controller - I have seen them for sale used. My understanding is that Western Digital made the controllers for IBM, so thats probably a good bet. Most PCs still have an ISA slot - and thats what most of the newer ESDI controllers need.

Hope that helps. Even if the CMOS battery fixes the problem, I would back up the data ASAP. It isn't a question of if a HD will fail, its when. Yours has had a very long life, and I wouldn't bet on it lasting much longer.

James

Collapse -

i got you

by paulisthebest3uk In reply to IBM PS/2 55 SX Error Mess ...

I dont know if this is still alive but both 161 and 163 codes indicate a dead dallas rtc battery.

Inside the ps2 sx 55 theres a chip called the dallas RTC. It contains a battery inside it.

When the battery dies, error codes 161 and 163 come up, and when you press F1 you get, you get thrown to IBM basic. The reason for this is because the older IBM 386 models if the hard drive wasnt detected in the bios it would just throw you to IBM Basic.

I can assist you on how to repair the machine if you still require it - email me on p a u l i s t h e b e s t 3 u k @ h o t m a i l . c o . u k (without the spaces) and quote ibm ps/2 workaround if you need my help. I recently repaired mine with exact the same problem

Collapse -

IBM PS/2 WORKAROUND

by green.brown.80 In reply to i got you

I have encountered the exact same problem with my PS/2 55SX that I dug out during a recent garage sale and any information would be most appreciated.

Thank you for your time.

Will

Collapse -

I also have same problem with old genealogy program in Dos and same error

by mommasaid In reply to IBM PS/2 55 SX Error Mess ...

I also have the IBM PS/2 55 SX. When I hit the F 1 key it brings up a screen now that has a list of things
1 list 2 run 3 load 4 save 5 cont 6 LPll 7 TRON 8 TRoff 9 Key o screen. I am horrible with computers but saved this one as it was the best computer I have ever had but it is full of 25 years of genealogy that is not on any of my new computers. What do I do next?

Collapse -

Help with old Dos IBM 55 SX

by mommasaid In reply to I also have same problem ...

Could someone please email me and tell me what to do to get into my old Dos machine. I have tried to contact the other two men who have posted here re: this problem. I was able to hit the F1 key but now I don't know what to do next. I can not get the full email of the two who have also posted here re: this. Maybe someone has their full email so I can contact them? I really need to get the data out of this machine. Thanks so much. Happy New Year.

Back to Desktop Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums