Question

Locked

IBM T22 won't turn on

By EStreetJerseyGirl ·
I have an IBM T22 laptop that was working perfectly fine until yesterday. I had turned it on and it started up, but went into setup mode (another issue that I need to fix after I get this one taken care of; for some reason the bootup defaults to setup instead of Windows unless I manually select the OS), so I turned it off by the power button. When I went to turn it back on, however, nothing happened. At all. No fan, no hard drive kicking on, nothing. The power supply appears to be working (the light is on on the laptop indicating it's plugged in). If this was a motherboard issue, would there have been any signs beforehand that it was about to keel over? The laptop IS almost 10 years old (it was born in 2000). Any suggestions on how to revive this thing?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

RE: "would there have been any signs beforehand?" ..

by OldER Mycroft In reply to IBM T22 won't turn on

I fear you may have already been getting the signs - when it defaulted to Setup. What did Setup show?

Did the laptop have SMART capability? Did it ever give you a status report for the HDD?

Which flavour of Windows?

Have you tried booting it without the battery attached?

Collapse -

Sorry, I should have elaborated a little further on the setup issue ...

by EStreetJerseyGirl In reply to RE: "would there have bee ...

That all started when the hard drive on another laptop bit the dust. I tried installing the OS on the new drive with it in the IBM because the other laptop was having issues recognizing the drive. After I tried to run the setup on the IBM with the new blank drive in it, for some reason when I reinstalled the old drive, it began to default to XP Setup instead of loading the OS, as had been default before. I fixed that issue also ... and now everything is running smoothly on all computers involved.

Collapse -

defaults

by balge In reply to IBM T22 won't turn on

hi
do you mean the BIOS resets to defaults?
10 year old CMOS battery finally giving up?


cheers!

Collapse -

Nope ...

by EStreetJerseyGirl In reply to defaults

... the computer wasn't powering up at all. I had to do a hard reset to get it to turn back on.

Collapse -

I'd try...

by cmiller5400 In reply to IBM T22 won't turn on

Unplugging it from AC power and pull the laptop's battery for 5 min. Then try and run it just on the AC power.

Collapse -

Close ...

by EStreetJerseyGirl In reply to I'd try...

I had to pull the battery, disconnect from AC power, hold the power button down for 10 seconds, then reinstall the battery and plug it back in. Never had that happen before ... but at least now it's up and running again.

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums