General discussion

Locked

iBook DNS broken-- ipfw??

By sgt_shultz ·
Hi, I realize I am posting this in pc tshooting...
Trying to help a friend put iBook on DSL/MSN. Don't know macs since os7 i think it was...
it is OS 10.3.3. the used 3 yr old iBook came for xmas from friend's ex who is professor at Duke. got laptop talking to dsl router ok, 4 green lights (power, dsl, internet, ethernet) but only can surf if i type in ip address, not by name.
so researched a bit on apple and so forth and tried the following, to no avail:
entered isp's dns addresses manually in Network properties.
created new Location with only port built-in ethernet port (which we have hard cabled to router and a green link light)
tried both manual and automatic ip's
forced dhcp renew multiple times
can ping dns servers and router
peaked in router to see Status 'connected' and no place to enter dns servers (tech said was dynamic)
looked for udp 53 (dns) entry in System refs/Sharing. did not see anything dns related. did not understand what i was seeing.
looked for firewall programs but didn't know what to look for. didn't see any. seems to be pretty bare bones. had vpn client and time synch program configured for duke on it but don't think it is interfering.
my feeling is if i brought my pc over, it would get on dsl and surf web.
something is blocking or not working dns wise on the laptop. i feel i have correctly input dns settings and the known workarounds for this problem and no joy. so looking at the unix stuff now: could ipfw be in place and me not know. how do i look what is the file name. i think i have the root account password...thanks in advance for help and ideas...

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Jaqui In reply to iBook DNS broken-- ipfw??

not really up on osx, but a few things:

is dhcpd installed and running?
since this is the deamon that will build the configuration for both ip and dns service when booting the nic.

dns may not be required by default, check the system settings, you should be able to tell the system to require it.

with the dhcp service, the config data is constantly getting rewritten, it effectively dumps the config when shutting down.

Collapse -

by sgt_shultz In reply to

Please see my comment for my conclusion about this problem.
Thank you very much for your post.

Collapse -

by sgt_shultz In reply to iBook DNS broken-- ipfw??

this turned out to be highly interesting little project. was blocked dns as i suspected, was from firewall, what else? and i can't fix it because we don't have su password or osx install disk. so had to close book on it, so to speak. duke put in plenty good protection with simple measure, imho..
what cracked this open for me finally was reading the screen during attempts to configure the built in firewall. it was telling me it couldn't because another firewall was installed. it dimmed the firewall configuration also. i dumb. i already scoured the system in search of firewall products, names gleaned from googling 'mac firewall software' and then scoured ibook for same to no avail.
what i have found out so far is that behind the scenes on osx is really IS unix, as everyone says. it comes up first and configures the built-in firewall via ipfw commands. if it 'finds it is not configured as it expects' as one internet tidbit put it, then it figures it has a third part firewall installed. and gives this bogus error message. sheesh. i always thought when i finally looked hard at a Mac that i would be awed at how insanely great but maybe i am not foresighted yet enuf because not learning linux, yet, either...when the time comes i'll grep with the best of them but not until it pays...anyhow, should have been able to sudo ipfw flush and get control of config again but we do not possess keys to kingdom. simple but elegant block. like bios password.

Collapse -

by sgt_shultz In reply to iBook DNS broken-- ipfw??

This question was closed by the author

Back to Desktop Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums