General discussion

Locked

IDE Controller Card - 5 IDE devices

By maxwell edison ·
I've got an older computer, an AMD-K6/333 with 128 MB RAM, running Windows 2000 Professional. I've got one hard drive and 4 CD-ROM drives installed; I'm using this machine as a CD-ROM server. The Asus P5A Super 7 Motherboard has, of course, two IDE channels for a maximum of four IDE devices. I installed an additional IDE controller card, a Promise Technologies Ultra 133 (TX2), to accommodate the additional IDE device.

Windows detects the card and installs the driver, but when I connect the card to any of the IDE devices, either the hard drive or any of the CD-ROM drives, the computer doesn't fully boot up - it gets hung up on the black screen before windows is loaded.

Now I had this working before with the same identical setup, but I recently had to reformat the hard drive and reload the operating system. And for the life of me, I can't remember what, if anything, I had to do before to make it work.

What am I missing here?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to IDE Controller Card - 5 I ...

you didn't change any hardware?
i bet it is you have to change the drive type to 0 or something in the pc's bios.
well, it wasn't reflashing the bios on the ultra 133 was it?

Collapse -

by maxwell edison In reply to

Nope, all the same hardware. The BIOS settings are fine. But thanks, anyway.

Collapse -

by dmiles In reply to IDE Controller Card - 5 I ...

Check the bios configuration to see if all of the devices are listed and the order of drive configuration is correct.

Reinstall the drivers to the IDE controller card

Collapse -

by maxwell edison In reply to

The BIOS settings are fine, and I already tried reinstalling the drivers - as well as different PCI slots. But thanks, anyway.

Collapse -

by zaferus In reply to IDE Controller Card - 5 I ...

I have a few things to go through - but perhaps getting the answer to these may help resolve your problem.

First of all lets look at the physical connections. I've used a similar Promise controller card in the past on an IDE server so hopefully I can help.

I'm guessing that the primary IDE onboard controller is your HDD - which contains your OS. If this has been moved to another location this could cause issues with your XP (NT) boot loader.

The Primary HDD is set to "master" (not cable select) with no other devices attached to the cable. In the BIOS the HDD is set to "autodetect".

There are no devices on the Secondary onboard connector, and in the BIOS this is set to "disabed".

Now, on the Promise controller - I'm interested in how the CD-ROM Drives are set up. Are they one master one slave? If Cable select is enabled on any of these drives - please put it to master/slave configuration. Cable select is great when it works, terrible when it gets to acting wonky. And it tends to get wonky with more complex setups. As well do you have the CD-ROM drives on the same channels as they were before? Perhaps there is an incompatibility with two that now are combined.

Now, for your cables: When you transfered everything over just check that you didn't use a SATA or ATA 100 cable on your CD-ROM drives and an older IDE cable for your HDD. While your at it unplug and reseat each cable to make sure one isn't just a bit unplugged causing a short which could cause this type of a problem.

If none of this works - reject this answer with comments on how everything is plugged in and we'll take a deeper look at your Promise card and drivers. Also include the driver version you installed please.

Zaf

Collapse -

by maxwell edison In reply to

BINGO!

My cables were setup, and drives jumpered as master and slave - both primary and secondary. I did, however, have a mixture of cables. I was using an 80 wire cable on the controller card connecting to one CD-ROM, and the older 40 wire on the rest. I changed it to the older style, 40 wire cable, and bingo, it detected all drives. (I'm certain it worked before, but how or why, I don't really care.)

Good call, zaferus. Thanks for your time.

Collapse -

by gralfus In reply to IDE Controller Card - 5 I ...

Peculiar. I hit my head against the wall for a long time when I tried to boot from this Promise card, but finally realized that I had to enable booting from SCSI in BIOS, because the system sees the Promise card as a SCSI card (in Windows device manager, the card shows up under SCSI).

But I don't know why it would care if you connected a CD-ROM to the card unless maybe CD is part of the boot sequence.

Collapse -

by maxwell edison In reply to

Good thought, something I considered, but see answer number 3.

Collapse -

by CG IT In reply to IDE Controller Card - 5 I ...

Max answer # 3 seems to be in the right direction. CD-Roms tend to run on the mambo when there are 2 or more on the cable and cable select is used. The O/S tends to not like the fact that the CD-Roms can't decide whos what. Had a similar problem on a server with 2 drives on the primary IDE channel and removing one caused the system to not boot. Changing the setup to master instead of cable select resolved the problem. Try a master /slave setup for your CD Rom setup .

Collapse -

by maxwell edison In reply to

Number 3 was indeed the right one.

Back to Desktop Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums