IDE to USB harddrive adaptor problem

By igravestock ·
Tags: Windows, Hardware

I have two old IDE harddrives that I was looking to access some data from. I bought a USB IDE/SATA adaptor and easily accessed the Western Digital WD1600 drive. I am using a laptop running Windows 7 (Home edition). The drivers were identified installed and it worked simply as I had expected based on the Youtube videos etc I had read.

However, when I came to repeat this with the older Fujitsu MPF3014AT 20Gb drive the drive isn't recognised. So I can see nothing in Disk Management in the Computer Management application and the drive doesnt seem to be recognised.

The drive spins & powers up, but the USB device doesnt seem to be recognised. The connector seems to connect to the IDE fine. The drive doesnt sound distressed.

So the things I have tried already are:

- rebooting and reconnecting the components in different orders, i.e. all connected at reboot, connect the adaptor only at reboot then the drive afterwards, etc
- changing the jumper settings from Master to Cable Select
- trying to connect to an iMac using MacOS to see if that was more successful
- had a good read of previous suggestions around similar problems or topics

As an alternative - if I cant make this work I would be interested in recommendations of UK based harddrive recovery firms that I could post this to and get the data by mailed back to me on a USB stick.

Thanks in advance

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by Simply_Michael In reply to IDE to USB harddrive adap ...

I think you should install the usb drivers again.

Collapse -

Have you tried to switch to a different USB port?

by Galaxy4643 In reply to IDE to USB harddrive adap ...

I have found this helpful when changing the HDD attached to the USB connector in the same session.

Collapse -

Check the Drive Jumpers

by TheChas In reply to IDE to USB harddrive adap ...

Check and / or change the drive jumpers.

Some drives will not connect if the jumpers are not set correctly for a single drive.

Try both cable select and single (master) with no slave present options.


Collapse -

Linux Boot CD

by Darryl~ Moderator In reply to IDE to USB harddrive adap ...

Have you tried booting the computer with a Linux Boot CD? Sometimes you have better success accessing older drives that way.
Note: you may have to connect the USB adapter before booting to the CD.

Collapse -

Use linux boot CD

by Simply_Michael In reply to IDE to USB harddrive adap ...

booting from Linux boot cd might be work if you have an idea how to use linux, yes moderator is right

Collapse -

Not uncommon fault

by mjd420nova In reply to IDE to USB harddrive adap ...

There are a large number of drives from many different manufacturers that have their own little disk & software to start the drive so the OS can recognize it. The only other fault I've seen is a good drive with a partition but nothing else is recognized by the OS. This happens when you try to look at a drive from one of the satelite or cable box DVR units. Data recovery can be pretty expensive. I done some myself but only with a same model drive unit and access to a clean room so I could swap the platter from the bad to a known good unit. Tedious and costly.

Collapse -

Try it in a PC

by SmartAceW0LF In reply to IDE to USB harddrive adap ...

I use these USB-IDE adapters daily. Here are a few issues/resolutions I have encountered with them regarding the systems failure to detect the drive.

1.) Wait. On some systems, the detection (and ensuing driver installation) of the USB adapter can take an unusually long time.

2.) Especially in scenarios where drives are swapped around in varying scenarios, connect the USB adapters plug to a different port. Then refer to item 1.

3.) Drive still not detected? Check the Disk Management Console for a drive needing to be "Initialized". If one is found, attempt to initialize it. If successful, problem solved. If not, refer to next item.

4.) If Disk Management Console detected the drive but was unable to initialize it, remove the drive from the adapter. Find a PC to install the drive into. Make sure the jumpers are properly configured for installation into the specific PC you are connecting it to. Once installed, power up the PC, ready to intercept the loading of the OS by hitting the proper key to enter the BIOS setup utility. Make sure BIOS detects the drive and registers its size correctly. If so, save and reboot to Windows (or other). If not detected by Windows, double check jumper settings and then Drive Mgmt Console. If you still can not access the drive and its contents, at this stage you will need to seek further professional help.

Collapse -

don't know

by miaip In reply to IDE to USB harddrive adap ...

I also don't know what to do.

Collapse -

Try no Jumpers

by jqbecker In reply to IDE to USB harddrive adap ...

I have found that some IDE drives need to have all jumpers removed. Then plug it back into a USB port, then skip down to SMARTACEW0LF's other suggestions below if still not working.

Collapse -

IDE to USB harddrive adaptor problem

by da.holland In reply to IDE to USB harddrive adap ...

Had you tried to assign a drive letter to it through Control panel > Administrative Tools > Computer Management > Disk Management ?

Related Discussions

Related Forums