General discussion

Locked

IdeaCom Technology Inc. - Input - IdeaCom HID Touch Screen (PS/2) MOUSE

By gcapp99 ·
Just in case some other unsuspecting fool like myself trusted Windows Update to load a new hardware driver only to completely lose PS2 mouse functionality, here's a fix:

First, use a USB mouse temporarily to navigate; In Windows Explorer, browse your C:\Windows\inf directory for "oemxx.inf" files. The "xx" is a number assigned by Windows- mine was oem11.inf.

Right-click it, click "Properties". Look at the "Created" date- it should be the same as the Windows Update session that installed it. Look at the "Modified" date- mine said Thursday, December 11, 2008 6:14:56am- the date the driver was packaged.

Delete it or drag it to a folder where Windows won't look for it, like My Documents.

Open Device Manager, expand HID devices and delete the IdeaCom device. Reboot. Done.

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Thanks gcapp

by stonewall77 In reply to IdeaCom Technology Inc. - ...

Stupid me as well. I downloaded the Microsoft update (which I couldn't find one bit of information on from their site) for the IdeaCom HID Touch Screen (PS/2) MOUSE as well and my PS2 mouse stopped working. I had loaded several updates at the same time, that one being one of them, and I suspected that that was the problem. I couldn't find it in my Add/Remove programs or in my device manager, so what I did was run out to Wal-Mart and look for a new mouse that came with a driver disk. I needed a new mouse anyway, so I bought a Microsoft Comfort Optical 3000 Mouse which is USB with a PS2 adapter. I installed the software and used the PS2 adapter just to check the port and that fixed my problem. I then shut down my computer and plugged my old mouse back in and it worked fine as well. It wasn't until I did all that that I did a Google search for IdeaCom Touch Screen. I found your post. I see you got this one fixed in a hurry. Nice job. I have a feeling we'll see a bunch of people coming along with the same problem.
Stonewall

Collapse -

Lost my PS2 Mouse after Update.

by leroykaump In reply to IdeaCom Technology Inc. - ...

Thanks!
Your info fixed my problem! Microsoft Update got me again!

Collapse -

Thanks gcapp

by marcus.bonner In reply to IdeaCom Technology Inc. - ...

Me too - your post just saved me a whole heap of aggravation - thanks again

M

Collapse -

Yup, me too

by Dianalytical In reply to IdeaCom Technology Inc. - ...

My laptop touchpad mouse quit working after this update. I was using a wirelss USB mouse so I didn't notice immediately. Fix worked great. Thanks!

Collapse -

IdeaCom HID Touch Screen update breaks mouse for XP VM too

by Eric Winn In reply to IdeaCom Technology Inc. - ...

I saw this in Microsoft Update when updating my XP SP3 VM running in Virtual PC on Vista x64 Ultimate host with virtual machine additions with pointer integration active. I thought I'd try it to see what it would do and when my VM finished rebooting I could not click on the user login icon.

I removed via device manager (it was showing with a yellow exclamation) and rebooted and my mouse was again working in the VM but I was prompted that device manager had found a new device and needed to reboot again.

I checked device manager and the IdeaCom HID device was back but now without the yellow exclamation.

I uninstalled again but before rebooting moved the oemxx.inf and oem.pnf to the VM's desktop. After boot, the found new device need to reboot to complete message again but now no HID showing. Went ahead and rebooted and it finally came up clean.

Re-ran Microsoft Update and the IdeaCom HID Touchscreen (PS2) was back in optional hardware updates where I checked it to not show this update again.

Fortunately, I use a lot of keyboard shortcuts so I could log in and navigate to device manager without a mouse.

There were some other posts in other sites suggesting manually deleting idcphid.sys from windows\system32\drivers. My VM device manager uninstall did not prompt me to remove the driver and I found it still present so moved it to the VM's desktop along with the oemxx.inf and oemxx.pnf for now.

Collapse -

IdeaCom Technology ...

by danyelt In reply to IdeaCom Technology Inc. - ...

many thanks for the solution! i have made a role back of my updates and that fixed the problem!

any how, u are not allone!

Collapse -

Thanks - Fix worked fine

by bob In reply to IdeaCom Technology Inc. - ...

I'd lost my touchpad on a laptop. I hooked up an external USB mouse, followed your advice, and on reboot, the problem was fixed.

Collapse -

Can't find the inf files

by jim.fam In reply to IdeaCom Technology Inc. - ...

I tried finding oemxx.inf files, and could only find oemxx.pnf files. I have 2 oem.pnf files for today's update, which is when I "updated" the IdeaCom update, and neither one relates to IdeaCom. Any other suggestions?

Collapse -

Can't find the inf files

by desone In reply to Can't find the inf files

I made the same mistake as you at first.

Go to the inf folder in Windows (for XP) - then look for the oem**.inf file created on Dec 11. 2008 6.14.56am. I put it into its own folder and XP couldn't find it. Don't forget to delete the hardware from the device manager before a re-boot.

Collapse -

INF files

by jim.fam In reply to Can't find the inf files

Thanks for getting back to me. I am running Vista not XP, and I can't find oem11.inf anywhere. Only oem11.pnf, and that is not the IdeaCom thing. All my files under oem are .pnf . I cannot find this file that you are talking about anywhere.

Back to Software Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums