Question

Locked

IE7 basic authentication data loss in domain

By mokusok ·
We have a problem regarding the storage of basic authentication data in IE7, on a Windows 2003 x64 Terminal Server, member of a domain.
Http data goes trough squid proxy server using basic authentication, therefore every user is prompted at first connection for their user name and password on proxy server. On the user name/ password form is a checkbox for remember authentication data. Even if the checkbox was checked, sporadically (generally the next day), the entered user name and password are lost, the user have to introduce it's user name/ password again. The data is kept after the restart of IE7 and after the relogin too.

The problem does not appear for all users at the same time, and we could not reproduce it. The same happens with all user names/passwords entered in the basic authentication pop-up window, not only with the proxy login data.
The user's home folder is stored on a samba file server. Application Data, Desktop and My Documents folders are redirected also.
We don't know exactly where the login data is stored, in some places appears that it's stored in the credentials file under Documents and Settings\<User Name>\Application Data\Microsoft\Credentials\<User SID> or
Documents and Settings\<User Name>\Local Settings\Application Data\Microsoft\Credentials\<User SID>. Indeed when a login data is entered, the credentials file is updated, but if we delete the file, the login data is not lost, so the real location should be elsewhere.
Data stored by AutoComplete is kept.


The rules are managed on a Domain Controller via Group Policy (GPO).

If I made modifications in GPO->User Configurations ->Administrative Templates -> Internet Explorer after a gpupdate command the new settings are visible on IE7-Internet Options.
Turn off the auto-complete feature for web addresses - disabled
Disable AutoComplete for forms - disabled
Turn on the auto-complete feature for user names and passwords on form - enabled
Turn on inline AutoComplete for Web Addresses - enabled
Turn off inline AutoComplete in Windows Explorer - disabled
Using this settings the IE7->Tools->Internet Options->Content->Auto Complete : all options are checked

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Networks Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums