General discussion

Locked

IIS 5.0 server won't display ASP pages

By gtork ·
W2K Adv Server with IIS 5.0--I am running this as a web server and can view .htm pages without a problem. However, when I try to view ASP pages, I get "HTTP 500 - Internal server error". I can view ASP pages from IE from different sites. I only get this when I try to view an ASP page located on this server. ASP is supposed to install when IIS 5.0 is installed. Is there a way to verify this? Why else might this be happening?

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

IIS 5.0 server won't display ASP pages

by chrandrob In reply to IIS 5.0 server won't disp ...

Could be a code problem totally unrelated to the server. Are you declaring "option explicit"? If so, and I recommend that you do, then I sometimes get this error if I have an undimmed variable -- or if I have a redimmed variable -- instead of the expected runtime error. An incorrect include reference may also cause this.

Do you have another server you can test the page on to rule out the server? Even a Win 9x running PWS will do. I do local testing on a NT Workstation running PWS before moving code to a test NT Server running IIS without any problems related to system differences.

If you get the error on another server, then you need to go through your code.

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

I have checked and double checked the code and that isn't the problem. I can't even view the .asp files that are in the iishelp files in the WINNT dir. And, unfortunately, I don't have another server to test on. Thanks anyway.

Collapse -

IIS 5.0 server won't display ASP pages

by gbworld In reply to IIS 5.0 server won't disp ...

This is not, repeat, not an ASP not installed problem. You have some sort of error on the server, either in the script or something corrupt in the ASP engine.

Try running regsvr32 on asp.dll and rule out a corrupt ASP engine.

Next, you need tofind the error in your script. Best bet on this is to turn off all on error resume next and find the first spot of error. Repeat until all errors are eradicated.

I saw the suggestion of Option Explicit. I recommend this, but it is unlikely to find the error. It is great for discovering typos, which are more likely to cause logical errors (wrong answer) than syntax errors (500 error conditions - **** ups).

If you can use this with PWS and IIS 4- then you most likely you have some code that is ASP 2.0 (IIS 4) compliant that has been changed in ASP 3.0 (IIS 5).

It is also possible that you are missing some DLLs that your scripts rely on and have on error resume next set on the original instantiation.

If all ASPs **** up, a corrupt ASP.dll file is a possibility. If only some, another option is you do not have the proper provider for your database. Installing the latest MDAC from www.microsoft.com/data should solve this.

Gregory A. Beamer
MCP: +I, SE, SD, DBA

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

I was able to regsvr32 the ASP.DLL fine. No asp pages work on the server, but do work on another server that I now have setup.

Collapse -

IIS 5.0 server won't display ASP pages

by chrandrob In reply to IIS 5.0 server won't disp ...

Are you using any include files? I upgraded my desktop to W2K this week and had to register .inc as an ASP include file before pages that included one could be displyed.

Save the following code as an ASP page on your server and see if it displaysokay:

<%@ Language=VBScript %>
<%option explicit%>
<%
Dim dbConn
Dim item

Set dbConn = Server.CreateObject("ADODB.Connection")

Response.write "<b>ADO Version: </b>" & dbConn.Version & "<BR>"
For each item in Request.ServerVariables
Response.write "<b>" & Request.ServerVariables.Key(item) & ": </b>" & Request.ServerVariables.Item(item) & "<BR>"
Next
%>

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

It didn't work. I can't even view the iishelp asp pages that are installed with IIS. Thanks anyway.

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

After digging deeper, I found that the following error shows up in the event log right after I try to access an ASP page:
"DCOM got error "Logon failure: unknown user name or bad password. " and was unable to logon .\IWAM_computername in order to run the server:
{3D14228D-FBE1-11D0-995D-00C04FD919C1}"

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

Point value changed by question poster.

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

I was able to find the answer. The problem was that the passwords for the IWAM_servername account were out of sync. To fix it, go to the inetpub\adminscripts directory in a command prompt and type cscript synciwam.vbs.

Collapse -

IIS 5.0 server won't display ASP pages

by gtork In reply to IIS 5.0 server won't disp ...

This question was closed by the author

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums