General discussion

Locked

IIS admin service keeps stopping

By emillanar ·
Our IIS service and WWW service keeps stopping without any logs being generated. I can start it and it will be fine again. After a few minutes it will stop again. I don't have any clue where to start troubleshooting. My feeling is that it's a problem with IIS4 because IIS admin and www services stops at the same time. We've been using it for the past 3 years and it's only 2 weeks ago when it did this problem. The only change I made was edit the users of Exchange. We are using Exchange5.5, OWA and IIS4. Thanks for the help.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

IIS admin service keeps stopping

by ankit0 In reply to IIS admin service keeps s ...

just uninstall the windows option pack and install it again in the same directory of Inetpub.
this a normal problem when the dll gets corrupted by your static site

Collapse -

IIS admin service keeps stopping

by emillanar In reply to IIS admin service keeps s ...

The question was auto-closed by TechRepublic

Collapse -

IIS admin service keeps stopping

by VinnyD In reply to IIS admin service keeps s ...

And remember to apply the patch for the Code Red Worm!

Collapse -

IIS admin service keeps stopping

by emillanar In reply to IIS admin service keeps s ...

The question was auto-closed by TechRepublic

Collapse -

IIS admin service keeps stopping

by emillanar In reply to IIS admin service keeps s ...

Thanks ankit! That's what I thought. If I am going to uninstall/reinstall IIS4 what are the consequences? Do I need to reset the Exchange and OWA settings? How about re-installing it (without uninstalling) will it overwrite the corrupt dll's?

Collapse -

IIS admin service keeps stopping

by mdeyette In reply to IIS admin service keeps s ...

You could always change your logging options to try to pick up on what is causing the issue. I think the change to the Outlook users is a red herring. If you run backups and the server's content is relatively static, do a system restore to the last date iot was working.

If not, uninstall and reinstall the option pack. Once you have the system running the way you want it to, I highly recommend backing up the server. You should also download a free tool called metaedit from Microsoft and use it to make a backup of the metabase (IIS' registry essentially...) If you experience trouble in the future, try restoring the metabase first.

Collapse -

IIS admin service keeps stopping

by emillanar In reply to IIS admin service keeps s ...

The question was auto-closed by TechRepublic

Collapse -

IIS admin service keeps stopping

by mdeyette In reply to IIS admin service keeps s ...

You could always change your logging options to try to pick up on what is causing the issue. I think the change to the Outlook users is a red herring. If you run backups and the server's content is relatively static, do a system restore to the last date iot was working.

If not, uninstall and reinstall the option pack. Once you have the system running the way you want it to, I highly recommend backing up the server. You should also download a free tool called metaedit from Microsoft and use it to make a backup of the metabase (IIS' registry essentially...) If you experience trouble in the future, try restoring the metabase first.

Collapse -

IIS admin service keeps stopping

by emillanar In reply to IIS admin service keeps s ...

The question was auto-closed by TechRepublic

Collapse -

IIS admin service keeps stopping

by mebudman In reply to IIS admin service keeps s ...

This is the behavior of a IIS that is being attacked by CODE RED I or II, apply the patch before taking out IIS. This is not a simple process, especially since you are running OWA on it.

Back to Windows Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums