General discussion

Locked

IIS Issue

By wasara ·
I installed XPPro SP2 and IIS 5.1 on a Laptop. I have not been able to access my localhost. I am getting a HTTP 500 Internal Server Error. In IIS Manager the Default Web site is running. Any Ideas

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by wasara In reply to IIS Issue

Point value changed by question poster.

Collapse -

by lowlands In reply to IIS Issue

Are you doing asp/apsx pages? If so run aspnet_regiis on your PC. If asp is the problem you should be able to access a simple html page on your site.
It can also be that that the IWAM_Computername user does not have access to the directory where your files are.

Collapse -

by wasara In reply to IIS Issue

I am trying to run asp/apsx pages eventually. I stripped out IIS and the .Net, reinstalled them in the same order including the Hotfix. Tried to access my localhost. Getting the same error. As per suggestion I gave permission to my IWAM_compu.. No Change. Appreciate more suggestions.

Collapse -

by BFilmFan In reply to IIS Issue

Can you ping the website by both IP address and name?

Collapse -

by BFilmFan In reply to

In hosting the website, did you publish a DNS record of the site's name?

Collapse -

by BFilmFan In reply to

You do it you want to reach it by name and not by IP address.

http://support.microsoft.com/default.aspx?scid=kb;en-us;315982&sd=tech

Collapse -

by wasara In reply to IIS Issue

Am trying to host the website locally.

Collapse -

by wasara In reply to IIS Issue

It turns out the solution is when installing IIS v5.1 on XPPro SP2 you have to check IIS go to Details>> Select world Wide Web Sevice, go to Details and check the Scripts virtual directory

Collapse -

by CG IT In reply to IIS Issue

well, where are you getting the 500 internal error? In the event viewer or is that a browser page that shows? IIS 6.0 500 Internal Error can mean a couple of things. More information of the actual error is needed. note: there are "friendly" 500 error messages which mask the actual error. This is taken from the Microsoft Help and Support for IIS "

Turn off the friendly error message option in the browser as follows: a. In Internet Explorer 5.x and 6.x, on the Tools menu, click Internet Options.
b. On the Advanced tab, under the Browsing section, click to clear the Show friendly HTTP error messages check box, and then click OK.
c. Close the browser.
Several frequently-seen status codes have "friendly" error messages that Internet Explorer 5.x displays and that effectively mask the actual text message that the server sends. However, these "friendly" error messages are only displayed if the response that is sent to the client is less than a specified threshold. For example, to see the exact text of an HTTP 500 response, the content length must be greater than or equal to 512 bytes. "

one question, did you create a web site other than the default site under web site in IIS? if so did you specify a home folder and specify the html page in the web sites properties?

Collapse -

by CG IT In reply to

well seems you solved your problem.

Jolly Good!

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums