General discussion


IIS requires auth with anon access

By Jeanne L ·
I am having problems getting this to work. It doesn't make sense to me why it is asking for credentials when I have it set for anon access. If I change it to anon access ONLY it just gives this page immediately without asking for authentication. Most authentication doesn't work either, only admin does.
Any ideas????

Error page:

You are not authorized to view this page
You do not have permission to view this directory or page using the
credentials you supplied.

Please try the following:
Click the Refresh button to try again with different credentials.
If you believe you should be able to view this directory or page, please
contact the Web site administrator by using the e-mail address or phone
number listed on the home page.
HTTP 401.3 - Access denied by ACL on resource
Internet Information Services

It is going to a direct page, that is not the problem. Here is more information....
I have a server named superman. I used tohave an alias in the DNS server for www pointing to superman. Recently I changed that to a host record, but it still seems to have some issues.
From my Windows 2000 Professional machine if I go to it will give me runtime errors and javascript errors on a few parts of the page, but will load kind of. If I go to it will ask for authentication. (and give me the error I posted before. If I go to http://superman/ralwc/wx/s.exe then it will work fine.

Unfortunately, trying to use that (superman - netbios name) on the clients computers doesn't seem to work, it still asks for authentication and normal users are not allowed still.

We have some network issues locally, and they have not been solved, but I don't know if this is related or if it's related to the fact that it's a
member server instead of a DC.

Thanks for any ideas. Jeanne

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

IIS requires auth with anon access

by Joseph Moore In reply to IIS requires auth with an ...

To me, this really sounds like a NTFS security permission issue. I would check the ACL settings starting on the root folder for your web site. Make sure that the IUSR_SUPERMAN account has rights to it. Then check the /ralwc folder, then /wx folder. Make sure that this user account has rights.

If the /ralwc folder is a virtual directory on another machine, make sure that the user account you use can still access it by itself. Remember, the IUSR account is a local machine account; it does not have rights when you go across a domain. So, when you set up virtual directories, you have to configure them to use domain-level accounts.

What is probably happening is you have the web site locked down too much, so the anonymous user web account can't access the folders. Your user account (probably an Admin-level account) does have access, but the normal users can't.
So, when you go to \\SUPERMAN\RALWC\WX\S.EXE it is using your user account for NTFS permission access since the entire transaction is inside your network. It treats your web request just as if you were browsing folders in Network Places. That is why it works that way.
Once you start to use the full URL and go out over the net, it tries to use the anonymous IUSR account and has security problems.
So, in my opinion, check out those ACLs! You will find the problem there.

hope this helps.

Collapse -

IIS requires auth with anon access

by Shanghai Sam In reply to IIS requires auth with an ...

I have checked the permissions and they seem to be ok. It allows everyone read access. I have even tried giving everyone read/write/modify permissions, everything except full control.
We called follett, the program vendor, and they said that we needed to use the local administrator account to do this.
Any other ideas? I can find nothing wrong with my permissions. What is the 'resource' it is referring to?
My standard html part of the web works ok, anonymous access is working just fine. These are 'virtual directories' I have added to the existing web. The files are on the same server, just not in the WEB directory.

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums