Question

Locked

IIS was unable to start the site.

By kdaure ·
Before I enabled Port 443 for OWA for external access, the Default Web Site was running and IIS starts and runs normally. Internally OWA worked fine. This is the only site configured in IIS 6.0 running W2003 SP2.
Now when I try to start the Default Web Site after adding the cert and enabling Port 443 in IIS, the following error appears "IIS was unable to start the site. Another site may already be using the port you configured for this site. Please select an unused port for this site".
Like I said this is the only site setup.
Any help would be highly appreciated.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Maybe...

by NS Designs In reply to IIS was unable to start t ...

try updating you IIS to a later version, the new updates my solve this problem,but HTTPS port 443 is all you need open on your firewall for secure OWA and
Outlook. U will have to setup up exchange interanlly is you want to do this. Are
running Exchange 2003?

Collapse -

Yes, exch 2003

by kdaure In reply to Maybe...

Yes, port 443 is already opened on our router to forward to our exchange 2003 server.

Collapse -

Solved!

by kdaure In reply to Yes, exch 2003

For the benefit of others who may encounter similar problem, this is what happened. When adding the cert and SSL was enabled, it created an extra port 443 in the Advanced option of IP Address (All Unassigned) under the Web Site tab. Just under Multiple identities for this Web site, there were two ports 80 and 443. However under Multiple SSL identities for this Web site, it listed port 443 only as default.
So when I removed port 443 from under Multiple identities for this Web site, leaving only port 80, I was able to start the Default Web Site successfully.
Then OWA was able to work internally and externally using HTTPS:// address for our site.

Collapse -

Reponse To Answer

by elizabethc In reply to Maybe...

kdaure, Thank you for posting about Port 443. It got me looking in the right location. When I installed a cert it changed our "Web site identification" IP from an assigned IP address to (All Unassigned), which is wrong in our case. Changing it back to the IP address and restarting IIS repaired the connection to the email server. This is one delicate process! Just looking at the options on that setting made IIS stop again until I restarted the www service.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums