Installation of Linux on P IV, 3.4 GHz, with SATA HDD

By Abbie Hasse ·
I am trying to install the Linux Red Hat 5.2 on above mentioned system through cd rom. I have tried expert and simple mode but invain. during initialization every thing looks ok except the following

hdb: non-ide drive, CHS=0/0/0
hdb: invalid Geometry,:0 physical heads?

these messages displays and at the end of initialization it gives the message

vfs:cannot open root device 08:22
kernel panic:vfs:unable to mount root fs on 08:22

and installation process doesnot proceed can any one help me what to do although i have seen many forums which shows bios changes in device configuration from enhanced to Legacy and i also used the the command
boot: linux all-generic-ide noapic nolapic

but it doesnot work. help me

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

It may be of no help but my one trick worked for me.

by Ron K. In reply to Installation of Linux on ...

I changed the BIOS hard drive settings from RAID to automatic or vice-versa. I can't remember exactly but there were three choices. One of them worked. <br>
To my unpracticed eye it looks as if you need a SATA driver, if you have SATA drives.

Related Discussions

Related Forums