General discussion


Installation problem of Red Hat 9,0

By samik ·
Hi there...
I have a problem with respect to the installation of Red Hat linux 9,0 in the SATA controler's hard drive....
And Installer gives me a message "An error while trying to read hard drive" ...
Why Linux can't recognize the hard drive...Please help me..
I have already Windows XP installed on this HD and have app. 7 GB free place on it for Linux

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by Jaqui In reply to Installation problem of R ...

red hat 9 is what 4 years old?
at that time sata was brand new tech.
try using a newer version of linux, if red hat, fedora core 3 or 4.

device manufacturers do not write drivers for linux, we have to write them ourselves.
test then get the code included into the distros.
that causes a year or two lag in device support.

Collapse -

by jmgarvin In reply to Installation problem of R ...

Slow down there Tex. You need Fedora Core 4 and even then SATA in Linux is still wonky.

SATA is coming along, but it has issues as of now. I would guess in 6 more months SATA will be fully supported.

The problem is that most companies don't write Linux you have to wait until the geeks reverse engineer SATA and write drivers for it.

Collapse -

by adeoye In reply to Installation problem of R ...

I had a similar problem, and was able to get it to install by tweaking a bios setting pertaining to the SATA drive. I worked on a HP desktop which came with a 36GB SATA drive, and successfully installed RH9. Play around with the BIOS if you REALLY need to install RH9, otherwise save yourself the hassle and go for a much more recent kernel.

Collapse -

by amcfrweac In reply to Installation problem of R ...

to the person who worked it out via the bios.... would you please provide information regarding HOW you did it. We have a Dell 370 with Intel 82801FR AHCI controller for SATA, and can't get Redhat server 3 or Fedora Core 3 to install. Have disabled SATA in bios... no good


Collapse -

cant installation red hat linux 9 in 80 gb sata hdd

by c_pointbsl In reply to Installation problem of R ...

plz techincal help ?

Collapse -

This may be a bit too late, but...

by john316kjv In reply to cant installation red hat ...

In your BIOS settings, you do NOT want to DISABLE SATA if you are using SATA drives. Rather, you'll want to change the "SATA Mode" or similar option. Some allow you to run SATA drives in "IDE Mode" or "Compatibility Mode" - but that does not mean yours does.

Windows XP has this same issue on some machines as well - which is why it gives the "Press F6" option during the initial portion of the setup routine.

Related Discussions

Related Forums