General discussion

Locked

Installing Canon CAPT for SUSE linux

By shamp22 ·
Hi,
I am trying to install Canon CAPT software for
linux, but when i go to install the package it
tells me that libpopt.so.0 is needed, so i search
for the popt file and it says it is installed.
Does anyone know what the problem could be? i am
trying to set up linux as my print server. So i
need the CAPT program.

Thankyou
Sam

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by jmgarvin In reply to Installing Canon CAPT for ...

Are you sure the libpopt.so is in the "right" place for the CAPT software? Where is the lib and where is the app looking for the lib?

Collapse -

by shamp22 In reply to Installing Canon CAPT for ...

The libpopt.so.0 file is in usr/lib and how can i find out where the CAPT software is looking for the file?

Collapse -

by Nico Baggus In reply to Installing Canon CAPT for ...

lookup the PATH en LD_PATH shell variables.

echo $PATH
and
echo $LD_PATH

also look into /etc/ld.so.conf
(run ldconfig after changes) and see if /usr/lib
etc is mentioned there I(I whould at leased expect so, otherwise you had more serious trouble..).

using tools like ldd "CAPTPROGRAM"
might also tell you what it expects.

or if it tries to dynamicaly link it try to track the program using strace or ltrace
and watch for all opens of the libpopt.so...

HIH,
Nico Baggus

Back to Linux Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums